Speak EV - Electric Car Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
159 Posts
Discussion Starter · #1 ·
Anyone else had this?

I was driving comfortably along dual carriageway, rural, primary route stuff.
And ACC would just suddenly drop from 70 to 40 - with the dash reporting that 40 had been detected.

It jars a lot. Good job there's been little traffic.

I've scanned and racked my brains, looking for what the car might have spotted - signs on a slip road, or a parallel road, or on an overbridge. But I can't see anything.

The best I can come up with is that the car is misreading a combination of signs - a clearway sign along with a national speed limit. Like this:
(That's the Eastern end of the A63 between the outskirts of Hull and the start of the M62)

The car will do this maybe 4 times over an 8 mile stretch.

Otherwise, the recognition system works fine.
 

·
Registered
Joined
·
444 Posts
It might have been GPS based data. Have there been roadworks on that stretch at some point in recent history?

Volvo used to do this with me on a stretch of road that had roadworks for about 8 months, it took another 3 after the completion of the roadworks before the updated GPS data stopped showing me the old limit.

I think you can turn off the auto speed limit stuff.

I'm intrigued on how CAR2X will affect things like misinterpreted speed limits, phantom traffic jams and car accidents in the future and how it prevents against misinformation from rogue transmissions but that's another discussion.
 

·
Registered
Joined
·
159 Posts
Discussion Starter · #5 ·
I don't recall any roadworks in the vicinity recently - although there is a huge set starting up in the centre of Hull now, where the speed reductions start miles away ... and the car behaves fine in that section. Likewise it is fine on the M62 itself.

The dash reports that 40 was detected ... which I think only happens when it sees a physical sign that overrides what the map/gps tells it.

I don't think I've been following anything with stickers that would cause the problem - certainly not that would cause repeat failures.
 

·
Registered
Joined
·
444 Posts
I've seen the dash display change when no sign is available or recently passed so I firmly believe that's when it's reverting to GPS data. Either way, it's using out of date or incorrect data and that's why I turn off the speed limit assist stuff and only use ACC on motorways/dual carriageways. I simply don't trust the data behind it otherwise.

It's supposed to be an aide but there's a very long way to go yet before it's useful.

Regarding stickers, the car knows when it's following a vehicle and it also knows what signs look like, their size and their static positions in the environment (ie side of roads or overhead gantries) so I'd find it unbelievable that it would accept a sign in the same position and speed as a truck as a valid data point.

If there was a circumstance where a vehicle and genuine road sign were in the same position, that would be a called an accident!
 

·
Registered
Joined
·
1,117 Posts
What version of firmware have you got? Mine used to do this. the suspicion was that it was it was getting confused with kph, 70 kph =44 mph. It would also decide that 50 signs meant 30 and 40 meant 25! V2.0 firmware fixed it. It occasionally reads signs on slip roads in error.
 

·
Registered
2020 VW ID3 Life 58kWh
Joined
·
489 Posts
What version of firmware have you got? Mine used to do this. the suspicion was that it was it was getting confused with kph, 70 kph =44 mph. It would also decide that 50 signs meant 30 and 40 meant 25! V2.0 firmware fixed it. It occasionally reads signs on slip roads in error.
I was just about to mention that, I've experienced similar issues where using ACC the car slows to 50 kph during roadworks on the motorway, mine is going in for 2.1 soon so I'll let you know if that fixes the issue.
 

·
Registered
Joined
·
128 Posts
Well there is a stretch of the road in my town where the limit is 40 but my ID.3 decides to accelerate to 80. Clearly no such speed limit in this country so this has to be something else than satnav data
 

·
Registered
Joined
·
159 Posts
Discussion Starter · #10 ·
I should be clearer...

I do see the dash display/change the speed sign under normal circumstances, where the number changes but there's no associated message. On these occasions I agree - GPS is the source for these changes, and any observations are quietly confirmed.

But the times when the dash puts up a whole message to say a speed has been detected, alongside a copy of the sign, is when I think it is working from observation to override GPS. I get that when I drive home, where the estate has a 10 sign that is sometimes visible, sometimes not.

These problems are definitely the latter kind.
 

·
Registered
Joined
·
159 Posts
Discussion Starter · #11 ·
I'm on 2.1 at the moment.

I had a location where the car saw a 30 on a side road ahead, as the main road curved to the right. That reliably triggered in the original software, but hasn't happened in 2.0 or 2.1

I don't think I've encountered an mph-kph disparity though. Always seems to be round mph numbers.
 

·
Registered
VW ID.3 1st Edition
Joined
·
86 Posts
You can check at HERE Map Creator - 2020 to see if the stretch of road has an incorrect speed limit. I've noted a few and reported corrections online there, it will be interesting to see if they ever get into a Navigation database update.
 

·
Registered
ID3 1st Edition in Glacier White
Joined
·
465 Posts
Well there is a stretch of the road in my town where the limit is 40 but my ID.3 decides to accelerate to 80. Clearly no such speed limit in this country so this has to be something else than satnav data
I assume you are not on 2.1 yet? Mine used to have a 90 mph section and assorted others which were clearly kph issues. All that has gone with 2.1.
 

·
Registered
Joined
·
128 Posts
I'm on the earliest FW (0564?)
 

·
Registered
VW ID3 Tour
Joined
·
1,682 Posts
I am 2.1, don't expect the ACC to get correct all the time, I had it reporting a 35mph sign just after coming out of a 20mph school area, I didn't see it.

It can detect something that is not there, I sooner it did that than the other way round.
 

·
Registered
Joined
·
344 Posts
I'm on 2.1 and had the display show a short section on a MSA at 100mph before it changed to 70mph.
 

·
Registered
Volkswagen ID.3 Life
Joined
·
2,693 Posts
I get this on the A1 southbound, just north of Borehamwood. There is a junction and the car will try to drop to 40mph even if you are in the outer lane. Either the GPS is inaccurate, or the map data is bad.
 
1 - 18 of 18 Posts
Top