Speak EV - Electric Car Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Please forgive a noob question, but I've just plugged in at the chargers in the northern quarter, and on a shared post only get 16 A.
Is this correct? or should I only get 32A when not sharing the post.

Sent from my SM-G960F using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Yes, the car charges at 7kw on my tethered Wallbox.
The post is shown as 7kw on the website and on zap map.
The cable came with the car (M3) and should be 32A, but I'm suspecting it may be the culprit.
I may have to try a different location.

I was just wondering what speeds others were experiencing on these chargers.

Sent from my SM-G960F using Tapatalk
 

·
Registered
Joined
·
395 Posts
There seem to be a few reports of slow charging on this network (GMEV now becoming BE.EV - charging points across Greater Manchester)

I charged at the street post on Hulme Street last week and didn't notice getting a slow charge.

Check out the thread GMEV is changing as well for some more reports.
 

·
Registered
Joined
·
1,873 Posts
Please forgive a noob question, but I've just plugged in at the chargers in the northern quarter, and on a shared post only get 16 A.
Is this correct? or should I only get 32A when not sharing the post.

Sent from my SM-G960F using Tapatalk
Is it one of the old Elekromotive posts - Port Street?
I know BE.EV have replaced most chargers but not all.
The old ones were sometimes fudged with a fixed 50-50 split rather than being dynamic as that made them slightly less unreliable.
 

·
Registered
Joined
·
221 Posts
The cable came with the car (M3) and should be 32A, but I'm suspecting it may be the culprit.
I may have to try a different location.
It world be pretty disappointing if the cable that came with the car didn’t support max charging rate - unless the car is 2nd hand and the cable was replaced for some reason. A 16A cable would be cheaper.
 

·
Registered
Kia e-niro 4
Joined
·
49 Posts
I know this is an old thread, but I charged on a "tall" Be.EV unit over the weekend which their website claims to be a 7kW charger but I was only getting half that, and I know that my car does 7kW through that cable from elsewhere. There was no other car on the charger for the whole time I was there

Definitely wasn't a problem, as it was a free charge and I was there for 8 hours!

Also, my Be.EV card doubles up as my Engie card :geek:
 

·
Registered
Ze50 GT Line Elmo Referral ISB2GG for mutual £50 off
Joined
·
308 Posts
Same happens to me on the velodrome, for Be.EV related issues, come here pls, @jaysmith08 is always around and is actually part of the staff running/planning the EV charging solutions across GM.
 

·
Registered
Kia e-niro 4
Joined
·
49 Posts
It was the Velodrome one I was at :)

Additionally, I sent some feedback about that one because in their app it's listed elsewhere (at the tennis courts)
 

·
Registered
2019 Nissan Leaf - 40kw
Joined
·
242 Posts
It was the Velodrome one I was at :)

Additionally, I sent some feedback about that one because in their app it's listed elsewhere (at the tennis courts)
Thanks for highlighting this. We have had some tripping issues with certain units that we're trying to get the bottom of and the Velodrome is one of them. There is a unit over the road at the Tennis Centre too which i think it working abit faster if you can adjust?
 
1 - 16 of 16 Posts
Top