Speak EV - Electric Car Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Picked up a new 40kwh Tekna today, an hour later after returning to the car, the centre screen did not come on. Turned off car, locked tried again, same thing, pressed every button known to man, still as dark as the night. Back to dealer, no radio, no maps, no cameras etc, several technicians and calls to Nissan, nobody has heard of this, has this happened to anyone out there? Cheers.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Picked up a new 40kwh Tekna today, an hour later after returning to the car, the centre screen did not come on. Turned off car, locked tried again, same thing, pressed every button known to man, still as dark as the night. Back to dealer, no radio, no maps, no cameras etc, several technicians and calls to Nissan, nobody has heard of this, has this happened to anyone out there? Cheers.
UPDATE: Thank you for all you replies, I've googled this overnight and can't find it happening either. The dealer had the unit out, power is going to it and power is getting to the on/off switch but that's as much as they can tell. It actually died on the Nag screen at start up, with out accepting that you can't progress, so my thinking is its the boot sector of the drive that has failed.

Nissan UK want the unit back to investigate, so they have dispatched a new one, hopefully Wednesday, I don't think they have heard of 24 hour couriers! In the meantime the dealer has leant me a petrol car, so not used to using that pedal on the left, I think its called the brake. Just to rub salt into the wound, as they were handing over the keys to the ICE, they drove my old 30kw Tekna past me off to its photo shoot, that one never let me down!!!!!!!!!!!
 
1 - 2 of 2 Posts
Top