Speak EV - Electric Car Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
557 Posts
Discussion Starter #1
I'm having problems getting my leaf to auto connect to my phone via bluetooth and wondered if there is anything I can do to remedy this?
Mine and the wifes Samsung S4 phones are both paired to the Leaf and both will connect manually by going into the settings but neither will automatically connect like they do with my other cars (audi and skoda). Because of this the bluetooth functionality might as well not be fitted as my wife wouldn't dream of going into the settings menus and I always forget until someone rings.
 

·
Registered
Joined
·
557 Posts
Discussion Starter #3
Have you checked the bluetooth settings in the phones?
I had a look and there is nothing to set really. Both phones are paired with the car ok and both connect fine manually. I deleted them both today and repaired them and now I am not sure if they are or aren't connecting automatically. The lack of an acknowledgement beep from the car makes it difficult to tell if they have connected themselves or not.
 

·
Administrator
Joined
·
11,835 Posts
It pops up on the screen to say connected when I get in with my iPhone.

Are you going in together (with both phones)? Maybe that's causing a problem if they both can pair? Complete guesswork.
 

·
Registered
Joined
·
557 Posts
Discussion Starter #5 (Edited)
It pops up on the screen to say connected when I get in with my iPhone.

Are you going in together (with both phones)? Maybe that's causing a problem if they both can pair? Complete guesswork.
It's happening with one phone at a time. I am not getting any acknowledgements but I thought it was connecting tonight, but maybe not. I'll have to do some more testing tomorrow to figure out whats going on
 

·
Registered
Joined
·
238 Posts
Might be me but why not just get in your car with the phone turn your car on and then try and make a call.
 

·
Registered
Joined
·
216 Posts
I see this message when switching the car on.

image.jpg

If a phone is connected you should see the status next to the clock, it shows battery as well after a little while.

image.jpg

Are you trying to get both phones connected at once? I don't think you can do that. They seem to connect in order of the priority set in the car menu. For example if my Wife and I both have a phone in the car, mine will connect, as it is number one on the list.
 

·
Registered
Joined
·
557 Posts
Discussion Starter #8
I see this message when switching the car on.

View attachment 1848

If a phone is connected you should see the status next to the clock, it shows battery as well after a little while.

View attachment 1849

Are you trying to get both phones connected at once? I don't think you can do that. They seem to connect in order of the priority set in the car menu. For example if my Wife and I both have a phone in the car, mine will connect, as it is number one on the list.
I'm not trying to connect both phones at once.
I've just been testing, and the car is connecting automatically to the last phone that was connected and showing the connected status. (I thought the signal strength was the carwings signal, thanks for pointing that out)
But if I then leave phone1 in the house and bring out the other paired phone, when switch the car back on I do not get the connected status popup. If I press the phone button on the steering wheel I get phone not found message or failed to connect type message, but if I go into the phone menu and manually select phone2 which is still on the list, but with grey icon instead of blue like phone1, it connects manually straight away. The only problem with this that from now on phone 2 auto connects and phone 1 doesn't auto connect any more.
There doesn't seem to be a way around this so in effect, it's only practicle to use the system with one phone. This can't be right, I must be missing something!
 

·
Registered
Joined
·
991 Posts
I think this may simply be an issue where you have two handsets paired? True removing one and see if it auto connects. Noticed the same issue in my wife's Qashqai, with two handsets paired it seems to lose the auto connect ability.
 

·
Registered
Joined
·
39 Posts
You are seeing the normal operation of the Leaf bluetooth system. It has been discussed elsewhere here. The system will only AUTOMATICALLY reconnect to the last phone in use. To swap to another handset you must do it manually. The system will now automatically connect to this new handset in future. There is no priority system. A poor implementation IMHO.
 

·
Registered
Joined
·
557 Posts
Discussion Starter #11
You are seeing the normal operation of the Leaf bluetooth system. It has been discussed elsewhere here. The system will only AUTOMATICALLY reconnect to the last phone in use. To swap to another handset you must do it manually. The system will now automatically connect to this new handset in future. There is no priority system. A poor implementation IMHO.
I was hoping this would not be the case. It's a shame such a good system is let down by a small oversight like this.
 
1 - 11 of 11 Posts
Top