Speak EV - Electric Car Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter #1
Has anyone had problems with BMW OEM charge cables? Frequent issues of it not initiating a charge? Lock errors etc?

With my purchase of the my i3s I negotiated the inclusion of the the OEM BMW 32amp Type 2 to Type 2 8 meter cable. In using this I had regular issues with the cable being rejected by chargers. On my home charger a Zappi unit it regularly rejected it creating a lock error. Myenergi the manufacturer of the Zappi have been excellent culminating with them coming out to my house to try and pin down the issue. We discovered there cable which came with a Jaguar i pace worked fine. Anyway they took the 8 meter cable leaving me with their working cable for the last month and have taken the BMW OEM and tested it, and also got the manufacturers of the Type 2 sockets for chargers involved. It seems the cable locking hole and also some of the other dimensions are just outside the TUV and Euro spec! This means of course that you can regularly get chargers being unable to lock the cable resulting in the charger being unable to initiate the charge.

It may be I have been unlucky with this cable, one from a bad batch, however I have recently seen on eBay people selling there cables with warnings like “works 50% of the time”. Just trying to understand the scale of the issue.
 

·
Registered
Joined
·
1,862 Posts
I was having a discussion about cables a few days ago when I had a charger problem. I was told not to rule out possible damage to the communications lead built into EV charging cables. Apparently, it can get damaged if a cable is inadvertently run over or twisted.
 
1 - 4 of 4 Posts
Top