Speak EV - Electric Car Forums banner

1 - 20 of 40 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #1
Is the cardiff west rapid handle/lever a bit fiddly or is it just me? This being my local rapid I only ever used this till today when I had chance to use Cardiff gate and it was easy peasy- got it going in one go . In cardiff west -its always 2-3 tries before the chargi g starts. Problem being the lever/handle catch doesn't fit/lock easily.
 

·
Registered
Joined
·
2,171 Posts
I'm not sure, last time I used that was about 2 months ago with no problems.

Check out this handy video just to clarify your using the connector correctly.

Using Yazaki connector/handle on Nissan-branded C…:

They aren't the most user friendly connectors really. There is a newer connector that Yazaki has been released which is alot easier to operate. Hopefully Ecotricity will start installing these once the old ones need replacing.
 

·
Registered
Joined
·
1,150 Posts
A number of them I use are well and truly foobarred. The handle mechanism seems to break and you end up having to manhandle the whole connector mashing it into the car till it locks. Release is a similar game of brutishness. I've given up reporting Membury west - been broken for months. Got well and truly stuck one time and took quite some time to release.

They've done nothing. On the second or third time I called for them to log it they said, well people are charging there so not an issue :rolleyes:o_O

Report it, ask them to log it, ask when it will be fixed. Keep reporting when not fixed in timeframe until one of you gives up :p
 

·
Registered
Joined
·
1,562 Posts
Is the cardiff west rapid handle/lever a bit fiddly or is it just me? This being my local rapid I only ever used this till today when I had chance to use Cardiff gate and it was easy peasy- got it going in one go . In cardiff west -its always 2-3 tries before the chargi g starts. Problem being the lever/handle catch doesn't fit/lock easily.
I've had three failed attempts at this charger & I've logged as many calls with Ecotricity. I can't get it to work with my Leaf.
 

·
Registered
Joined
·
396 Posts
They aren't the most user friendly connectors really.
Or worse. There are no written instructions. No dealer training. No user guide that I have been able to find. I remember the rising wave of panic on my first attempt to use one of these as it dawned that I was stuck with my car attached to the charging station at a motorway service station with nobody around who would have any clue about EVs.

Thank you to the people who posted videos of how to work these connectors.
 

·
Registered
Joined
·
1,160 Posts
Simple "Press twice to release" next to black square button on the top would prevent majority of this damge IMHO.
 

·
Registered
Joined
·
40 Posts
It is officially broken. I had to go to Sarn services, where there was a queue of Leafs waiting to use the unit.
 

·
Registered
Joined
·
230 Posts
I went to Wales last Sunday and all the services on the M4 were working apart from as above Cardiff West East bound (West bound was ok on the way up), well it might have worked but you can't get it to lock onto your car, good job i had enough charge to get to the next one just.On my way i had to wait for two Mitsubishi Outlander's to finish at two different locations, and i unplugged one that had finished charging so i could use it.I dont know if thats strictly correct but i waited with my car and when the owners came out 15 mins later i explained and they were great saying they had no problems at all.Never saw one Leaf at all.
 

·
Registered
Joined
·
2,171 Posts
The Cardiff West rapid has had a dodgy plug for months now. I have managed to initiate a charge by pushing the internal connector (what goes forward when you pull the handle) manually. I had an initialization error before doing this.

What error did you get.

Sarn Services is my local rapid. It's getting busy there as it is (bumped into 2 forum members recently). It's nice that they are getting used, and that there are a growing number local EV owners. Not handy if your in a rush though and need a quick 10min charge. Hopefully @Ecotricity can double up the rapids along the South Wales M4.
 

·
Registered
Joined
·
1,562 Posts
It's STILL broken? It's been almost 6 months!

I hate bashing a free service, but that is mad, especially when it's a mechanical fix - unless it's a spare parts supply issue.
 

·
Registered
Joined
·
2,171 Posts
It's STILL broken? It's been almost 6 months!

I hate bashing a free service, but that is mad, especially when it's a mechanical fix - unless it's a spare parts supply issue.
Hopefully their waiting for stock of the new Yazuki connector ☺. Still, it should have been sorted by now even if it is a free service.
 

·
Registered
Joined
·
40 Posts
Definitely still broken. It is offline according to ecotricity. I rang them and they had no schedule for repair, but it will be.
 

·
Registered
Joined
·
17 Posts
I've always had problems here as well, I don't think the sloping car park helps when trying to line up the connector. The pumps also caused warning lights to appear on the dash after starting the car following a charge, turing the car on/off clears them.
I did spot planning permission docs on the lamppost not that long ago so there should be a second charger appearing soon.
 

·
Registered
Joined
·
61 Posts
Discussion Starter #16
Looks like the connector has been repaired/replaced. Worked perfectly first try :))
 

·
Registered
Joined
·
2,171 Posts
Tried it at 10am this morning. The handle is still broke.

You just need to make sure you push the internal connections in (the action that the handle does when you pull it).
 

·
Registered
Joined
·
1,562 Posts
Yeah, the handle is stil fubar. But like Dean says, it is possible to get it connected if you push hard enough. Took me two attempts.

Hopefully they'll be doubling up this site soon too, there's another leaf waiting next to me as I type this!
 

·
Registered
Joined
·
40 Posts
I'm having serious issues with rapid chargers. Only 1 out of 3 has worked for me. Failed at M4 Cardiff West, IKEA (today). Succeeded at M4 Sarn services.

I thought it must be me so I went to wessex garages in Cardiff to have a go at theirs. Worked first time.

I'm feeling really let down by the network at the moment. If I can't get rapid chargers to work (when others can) I can't go very far in my car.
 

·
Registered
Joined
·
2,171 Posts
Was you having an initializing error on the Cardiff West rapid?

What error did you have on the IKEA one?
 
1 - 20 of 40 Posts
Top