Speak EV - Electric Car Forums banner

Chargeplace Scotland changing from Charge your Car to SWARCO eVolt

22545 Views 259 Replies 32 Participants Last post by  Duncan
News has just hit that Chargeplace Scotland (CPS) who have used Charge your Car for their authentication and billing for the last several years will be switching to SWARCO eVolt starting in July:

This is an interesting albeit not unexpected change. What does it mean for end users?

Will existing RFID cards continue to work or do we need new ones? Will CPS accounts (which are basically just CYC accounts and use the same CYC app) be migrated across or will we be needing to create new accounts?

Will CPS cards stop working on CYC sites in England and will CYC cards stop working on CPS sites in Scotland?

Will CPS finally get their own mobile app instead of just using the CYC branded app and a fairly useless web browser based lookup?

While I of course recognise eVolt and a lot of rapids on the CPS network are already eVolt units, I have no knowledge of their ability to run a back end authentication and billing system, although they're unlikely to be worse than CYC.

So, good news? Bad news? Ambivalent ? :unsure: To be honest it's quite a while since I've used a CPS charger!
1 - 6 of 260 Posts
Just chipping in to say the local CPS 22kW post I use most often worked fine with my old CYC card last night. (I think I decided to join CYC rather than CPS so as to be able to use their chargers if ever in England). Just waiting on my new RFID card now, which is hopefully in the post.

However, no charging session showing yet in my new Swarco e.connect account and I can't access the CPS website with my old userid and password. CPS is giving me a passive aggressive "forgotten your password?" message, but the Swarco website was doing the same yesterday until it fixed itself, so hopefully I'll be able to access the CPS site today at some point.
Thanks Hedley, tried the link but it's now completely down, in continuation of @farmergiles input. Will give it another whirl later.
Nope, still works for me, just tried it. It took 30secs to log me in and then was slow to list my charges. But if you were with CYC, this may explain it.
Did you receive an email asking for permission to migrate your account from CYC to Swarco?
Yes thanks, I got the email and acted on it. I have a working Swarco e.connect account and a new direct debit, although the charge I did yesterday on a CPS isn't showing up, not entirely unexpectedly based on others comments.

Hedley's link is working for me now, but it just takes me to my old CYC account page.

I'll give it another day or two before I complain, because I couldn't even access my Swarco account yesterday until late on in the day, so they're making progress even if they're not the best at communicating it.
Have you tried your existing card? It may still work as they only stated that CYC cards would no longer work.
The variation in people's experience is remarkable, isn't it? My card is actually a CYC card (it says that on it - I assume the CPS cards have CPS branding?) and it worked fine on a CPS post yesterday.
I haven't done a long trip in my car yet but was hoping to head north from Hampshire in September after the schools go back and would at least get as far as Falkirk and Kinross to visit friends. Will all the important issues have been sorted by then?! I'd hope to get a CPS card and a functioning app..
We all hope they will be fixed by then, but should that not be the case, there will be less pressure on the charger network because @farmergiles will have had his thrombo by then, probably found lying in Lochgilphead car park with his phone clenched in his on hand on the CPS twitter feed :)

(Just joshing @farmergiles - I'm in the Lochgilphead area this weekend and do appreciate your regular updates on the local charger status)
Me too, near Tarbert for a week from Sunday.
Lovely spot Tarbert. We stayed in the converted Dutch canal barge on the quay there and had a great few days.
  • Like
Reactions: 2
1 - 6 of 260 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.