Speak EV - Electric Car Forums banner

Chargeplace Scotland changing from Charge your Car to SWARCO eVolt

22612 Views 259 Replies 32 Participants Last post by  Duncan
News has just hit that Chargeplace Scotland (CPS) who have used Charge your Car for their authentication and billing for the last several years will be switching to SWARCO eVolt starting in July:


This is an interesting albeit not unexpected change. What does it mean for end users?

Will existing RFID cards continue to work or do we need new ones? Will CPS accounts (which are basically just CYC accounts and use the same CYC app) be migrated across or will we be needing to create new accounts?

Will CPS cards stop working on CYC sites in England and will CYC cards stop working on CPS sites in Scotland?

Will CPS finally get their own mobile app instead of just using the CYC branded app and a fairly useless web browser based lookup?

While I of course recognise eVolt and a lot of rapids on the CPS network are already eVolt units, I have no knowledge of their ability to run a back end authentication and billing system, although they're unlikely to be worse than CYC.

So, good news? Bad news? Ambivalent ? :unsure: To be honest it's quite a while since I've used a CPS charger!
241 - 260 of 260 Posts
Thanks for all your replies.
I've emailed them back asking them to add my card to my account. Lets see how quickly they respond.
On the upside I've managed two trips from Glasgow to Aberdeen without a hitch although sounds like it may have been luck more than anything else. Also sounds like I got a free charge on Sunday so thanks to my generous friends giving me "petrol money" I've made a profit from my journey 😁
  • Like
Reactions: 1
My working? CPS card hasn't been migrated from what I can see, its not showing on my account. Even though one of SWARCO staff said it was good. Nevermind, not used my card since handover, I just use my work ID as the network is CF'd and all our charges are currently free.

Wonder who's going to pay the Councils for their lost earnings? TS won't be interested, and it'll cost more than the contract is worth to SWARCO.
  • Like
Reactions: 1
Just to confirm what some above have said: if the charger is a "free to use" and goes out of comms, you can start a charge with any RFID card e.g. I used my Staff Card yesterday morning to start/stop a charge session.
Yesterday I had trouble starting a charge with the app so I tried using my Swarco card and somewhat to my surprise it worked. I assumed they had decided to let Swarco cards work as well as branded CPS cards but perhaps it was just that any card works at the moment.
  • Like
Reactions: 2
Yesterday I had trouble starting a charge with the app so I tried using my Swarco card and somewhat to my surprise it worked. I assumed they had decided to let Swarco cards work as well as branded CPS cards but perhaps it was just that any card works at the moment.
Any card works whilst they are on free vend. I used a Swarco E-connect card on sunday.

The app doesn't seem to work unless your account has a card listed and Swarco have not been migrating CPS cards as they said they would. (they only said CYC branded cards could not be migrated)
  • Like
Reactions: 1
2
email recieved today:

149274


Clicked the link and got this:

149275
See less See more
So they want you to buy a new card unless you were a CYC customer by the looks of it.
I've just had the same email but I can login so now I have used the link to order a new card.
I also get an alert about setting up a payment method but then thanks for using Gocardless.

Update: Just noticed that they are using Gocardless after all.
We were told:
1) we could keep the old CPS car
2) new DD called Swarco e-volt would have to be set up.
So more BS from Swarco.

If I could be bothered I'd complain to TS.
email recieved today:

Clicked the link and got this:

View attachment 149275
Did you click the My account link - this worked for me.
Also you are shown logged in, so try logging out and in again.
Used by pre-handover CPS card (bought in April 21) on a CPS rapid in Selkirk without any problem. Authenticated it said, and away it started charging.
However, I had done the re-authenticate after SWARCO took over, updated some details etc. But I cannot see in My Account the CPS RFID card. I have a Direct Debit set up. So was a little unsure whether it would work or not.
Used by pre-handover CPS card (bought in April 21) on a CPS rapid in Selkirk without any problem. Authenticated it said, and away it started charging.
However, I had done the re-authenticate after SWARCO took over, updated some details etc. But I cannot see in My Account the CPS RFID card. I have a Direct Debit set up. So was a little unsure whether it would work or not.
Free vend so won't show up in your account and looks like no existing CPS cards can be migrated and we will all have to apply for a new card. (I'd speculate that CYC/BP are preventing migration as they own both CYC and CPS cards but I do wish CPS/Swarco would be up front with what's happening)
Did you click the My account link - this worked for me.
Also you are shown logged in, so try logging out and in again.
Cheers. Logged out and clicked the link and it let me reset my password as requested
So they want you to buy a new card unless you were a CYC customer by the looks of it.
I've just had the same email but I can login so now I have used the link to order a new card.
I also get an alert about setting up a payment method but then thanks for using Gocardless.

Update: Just noticed that they are using Gocardless after all.
We were told:
1) we could keep the old CPS car
2) new DD called Swarco e-volt would have to be set up.
So more BS from Swarco.

If I could be bothered I'd complain to TS.
I've been patient so far, but this is a shambles. As an absolute minimum, those with existing cards should get new ones with the fee waived. Hard to avoid feeling that I have been, at best, misled, and, at worst, told lies.
  • Like
Reactions: 2
Has this been posted yet?
  • Wow
Reactions: 1
Has this been posted yet?
Yes but its worth repeating
  • Like
Reactions: 1
Has this been posted yet?
Two of us provided quotes and the journalist said he will be monitoring the situation with a view to writing a follow up.
Two of us provided quotes and the journalist said he will be monitoring the situation with a view to writing a follow up.
Press and Journal has an article touches on SWARCO CPS. Normal rubbish journalism from P&A, full of errors and advertorial quotes from various interests.

What's the National saying?
Interesting discovery on the CPS/Swarco Twitter feed. They've not posted nor replied to anyone since the 26th.

But yesterday they replied to Scott Milne, transport & media reporter in Fife and Tayside who shared the Dundee Courier article and hired an I3 for a charging test drive.

"435 charging sockets currently online and working in Tayside today. 15 have issues and manufacturers have had tickets raised for onsite visit. How’s the journey going?"

Clearly very sensitive to critical comments from the media, but happy to ignore EV drivers just wanting a charge....

As regards Scott Milne.

I asked how he was starting a charge, app, CPS card or other rfid card. CPS came back the answer.

So my next question was:

"have you checked your account for the charge, if not it would have been a free vend and any card would have worked?" Says he can't check his account as he didn't use his card.

(Maybe Swarco gave him a free one? Sorry, I am a cynical old git, but a few days after the Dundee Courier article, this guy pops up doing a charger test and Swarco are all over him..)
See less See more
  • Like
Reactions: 1
We're still on holiday in Fort William with my wife's PHEV 225xe so I just took it to plug in at the nearby charging point (Three Monkeys Climbing). When I arrived there was a Zoe in the right hand space and as the cable won't reach the BMW's charge port if I park in the left bay I asked the lady if she would mind moving. She said she was just on the phone trying to get them to start the charge as her card wasn't working. I waited until she gave up on them and suggested she try another card (she had a CPS card) as I'd heard any RFID should work but she just got back in her car and drove off muttering about no working points in Fort William.

I then pulled into the right hand space, tapped my Swarco card and plugged in. Charge started without a problem.

Should I have been more forceful and insisted she move to the other space then started the charge for her? I don't like to bully but she needed the charge a lot more than I do.
We're still on holiday in Fort William with my wife's PHEV 225xe so I just took it to plug in at the nearby charging point (Three Monkeys Climbing). When I arrived there was a Zoe in the right hand space and as the cable won't reach the BMW's charge port if I park in the left bay I asked the lady if she would mind moving. She said she was just on the phone trying to get them to start the charge as her card wasn't working. I waited until she gave up on them and suggested she try another card (she had a CPS card) as I'd heard any RFID should work but she just got back in her car and drove off muttering about no working points in Fort William.

I then pulled into the right hand space, tapped my Swarco card and plugged in. Charge started without a problem.

Should I have been more forceful and insisted she move to the other space then started the charge for her? I don't like to bully but she needed the charge a lot more than I do.
Sounds like you were being pretty helpful, not sure what more you could have done.😀
We're still on holiday in Fort William with my wife's PHEV 225xe so I just took it to plug in at the nearby charging point (Three Monkeys Climbing). When I arrived there was a Zoe in the right hand space and as the cable won't reach the BMW's charge port if I park in the left bay I asked the lady if she would mind moving. She said she was just on the phone trying to get them to start the charge as her card wasn't working. I waited until she gave up on them and suggested she try another card (she had a CPS card) as I'd heard any RFID should work but she just got back in her car and drove off muttering about no working points in Fort William.

I then pulled into the right hand space, tapped my Swarco card and plugged in. Charge started without a problem.

Should I have been more forceful and insisted she move to the other space then started the charge for her? I don't like to bully but she needed the charge a lot more than I do.
Probably would have been worth using your card to start her charge as you are probably not going to be charged for your own charge. (check your account, and also, if the app doesn't work it means there isn't a card registered)
Probably would have been worth using your card to start her charge as you are probably not going to be charged for your own charge. (check your account, and also, if the app doesn't work it means there isn't a card registered)
Yes, that's what I think I should have done. I suggested she try another card but should have just offered to start it for her. I'm pretty sure the charger lets go of the cable when your done without needing the card to stop it (it asks for the card but I was able to unplug without using it last time I used that charger).
241 - 260 of 260 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top