Speak EV - Electric Car Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
My 2015 B-Class Electric Drive hasn’t been totally charging recently, this issue has started week ago.
It is like whenever I plug it for charging it starts charging at the beginning and after a couple of hours the charger flashes red light and the vehicle stops charging. I have tried anther charging plug but same issue happened.
Does anyone experienced this issue before
 

·
Registered
Joined
·
40 Posts
My 2015 B-Class Electric Drive hasn’t been totally charging recently, this issue has started week ago.
It is like whenever I plug it for charging it starts charging at the beginning and after a couple of hours the charger flashes red light and the vehicle stops charging. I have tried anther charging plug but same issue happened.
Does anyone experienced this issue before
Maybe you could try an Ohme cable to charge your car. If you could borrow one from someone local. I use my Ohme cable to charge at 5p/kWh during the night. It regulates itself as to starting and stopping. It may even indicate what the problem is? Other than that it sounds like a call to Mercedes help line is required?
 

·
Registered
Joined
·
611 Posts
When you say you tried another charging plug was it a different cable but on the same charger you mean? Do you have the "granny" cable with the 3 pin plug to try and see if its the same?

Cheers.
 

·
Registered
Joined
·
807 Posts
@Tanurireb I’ve been having the same problem. Won’t charge on my home charger but will charge on a granny charger fine.

A mechanic stated that he has seen someone post somewhere else with exactly the same symptoms and eventually had to have the on board charger replaced.

anyone else had the same problem?
 
1 - 4 of 4 Posts
Top