Speak EV - Electric Car Forums banner
1 - 20 of 20 Posts

·
Registered
Joined
·
376 Posts
Discussion Starter · #1 ·
My M3 has just been updated to v.2021.24.5 and now the dashcam icon has disappeared! The sentry icon is still there (either grey for off, or red for on) but there is no way to view dashcam footage as there is no icon to press to launch the viewer. And I'm assuming that the dashcam is not recording either when I drive.

I've tried rebooting the car (soft and hard reboot), several times, reformatting the USB drive several times, trying a different brand new USB drive, but no dice.

Has anyone else had the same problem?
Gadget Rectangle Communication Device Font Electronic device
 

·
Registered
Joined
·
382 Posts
Yes, similar to your issue but I could see the greyed out dash cam icon but couldn’t get a red dot or to record anything even sentry. Ended up going into the service centre and having some modules reset to factory settings. Apparently it had lost some software 🤦‍♀️
 

·
Registered
Joined
·
376 Posts
Discussion Starter · #3 ·
Yes, similar to your issue but I could see the greyed out dash cam icon but couldn’t get a red dot or to record anything even sentry. Ended up going into the service centre and having some modules reset to factory settings. Apparently it had lost some software 🤦‍♀️
I've just booked a service visit at home. It didn't offer me any options for the local service centre.
 

·
Registered
Joined
·
382 Posts
Dunno then, I booked it in under ‘other’ not software. It had been looked at before and the red dot was on the dash cam icon, until I put it in drive. Never seen the red dot again until I picked it up from the service centre. Joys of Tesla ownership, 😭
 

·
Registered
Joined
·
376 Posts
Discussion Starter · #5 ·
Dunno then, I booked it in under ‘other’ not software. It had been looked at before and the red dot was on the dash cam icon, until I put it in drive. Never seen the red dot again until I picked it up from the service centre. Joys of Tesla ownership, 😭
The local service centre just called me to say that according to their system the car says no usb device is present! The plot thickens!
 

·
Registered
Joined
·
185 Posts
It seems like this is their third attempt at this particular software update. I didn't "notice" any issues since updating to 24.5, but I'll have to check if my dashcam still exists. If you have a media usb plugged in the centre console it's recommended that you take it out, put your sentry drive in the glove box and let the car find it before plugging the media usb back in the centre console. Otherwise the car gets confused over which drive it's supposed to use (mine does anyway).

Fyi, my car skipped 24.3 and 24.4... and I haven't been in it since Thursday to notice anything untoward
 

·
Registered
Joined
·
685 Posts
Got 24.5, and the dashcam icon is there and working.

And I'm very pleased they finally introduced the feature where if you tap the percentage or miles remaining next to the battery it switches between the two with a single tap.

Haha, I've waited more than 2 years for this feature, it's worth the wait :D(y)
 

·
Registered
Joined
·
376 Posts
Discussion Starter · #11 ·
It seems like this is their third attempt at this particular software update. I didn't "notice" any issues since updating to 24.5, but I'll have to check if my dashcam still exists. If you have a media usb plugged in the centre console it's recommended that you take it out, put your sentry drive in the glove box and let the car find it before plugging the media usb back in the centre console. Otherwise the car gets confused over which drive it's supposed to use (mine does anyway).

Fyi, my car skipped 24.3 and 24.4... and I haven't been in it since Thursday to notice anything untoward
I have a 2020 Model with no usb socket in the glove box - just one usb socket under the wireless phone charger. The same socket that the drive has always been plugged into!
 

·
Registered
Joined
·
185 Posts
I have a 2020 Model with no usb socket in the glove box - just one usb socket under the wireless phone charger. The same socket that the drive has always been plugged into!
Ahh of course. I still haven't been in my car to check but I'm wondering if it's not affecting refresh cars. I just remember mine wouldn't recognise the sentry drive if I plugged it in after plugging in a drive with music on
 

·
Registered
Joined
·
376 Posts
Discussion Starter · #13 ·
Ahh of course. I still haven't been in my car to check but I'm wondering if it's not affecting refresh cars. I just remember mine wouldn't recognise the sentry drive if I plugged it in after plugging in a drive with music on
I've never used my drive for music. It's the SanDisk 512gb USB 3 version recommended by Tesla!
 

·
Registered
Joined
·
115 Posts
Yes. Several times - and another brand new drive. No joy.
I'm guessing you aren't formatting it using the car? but on a pc or something?
If you are using usb extension cables be aware that some cables can only be used for charging. If you have your usb drive plugged into a usb extension cable like this then it wont show.

To troubleshoot that i think ensure its plugged directly into car usb socket. Dont use extension. Then check if to see if usb drive shows in the format menu.
 

·
Registered
Joined
·
376 Posts
Discussion Starter · #15 ·
I'm guessing you aren't formatting it using the car? but on a pc or something?
If you are using usb extension cables be aware that some cables can only be used for charging. If you have your usb drive plugged into a usb extension cable like this then it wont show.

To troubleshoot that i think ensure its plugged directly into car usb socket. Dont use extension. Then check if to see if usb drive shows in the format menu.
Always formatting in the car. No extension. Drive shows on format menu but dashcam icon disappears after formatting. Same with all drives so I think there's a fault with the USB port in the car. Service visit booked as Tesla can't even see the USB port at their end!
 

·
Registered
Joined
·
376 Posts
Discussion Starter · #17 ·
I'm sure you've tried this already but have you plugged it in both USB sockets to see if the other one works?
Mine is a 2020 model so there's only one USB port (under the wireless phone charger). The other socket is a USB 3 which connects to the phone charging pad itself.
 

·
Registered
Joined
·
115 Posts
Mines a 2020 also, I have two USB A ports in the center console.
Do you have a port in the glovebox?
 

·
Registered
Joined
·
376 Posts
Discussion Starter · #19 ·
Mines a 2020 also, I have two USB A ports in the center console.
Do you have a port in the glovebox?
Mine is an Oct 2020. I have no USB socket in the glovebox, only one normal one under the phone charger and also a USB C socket under the phone charger.
 

·
Registered
Joined
·
376 Posts
Discussion Starter · #20 ·
Update : Dashcam and Sentry icons now restored. It had to be done at the local service centre in the end (not at home) as it required a car firmware update to reset the USB system in the car. No charge for the fix as it was under warranty, as you'd expect.
 
1 - 20 of 20 Posts
Top