Speak EV - Electric Car Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
233 Posts
Discussion Starter #1
Well installed my dashcam today! All went pretty well only difficult part was the a-pillar. As it has an airbag so the clips are very hard to remove. Running the wires is very simple along the top down the pillar into the side panel. Then fished though to the fuse panel. There is also a convenient place to ground!
126940
126941
126942
126943
126944
126945
126946
126947
126948
126949
 

·
Registered
Joined
·
233 Posts
Discussion Starter #3
It’s on a switched circuit I believe it’s the running lights. The wiring is just a hardwired nextbase kit.
 

·
Registered
Joined
·
233 Posts
Discussion Starter #5
They are only a fiver off eBay. Mine came with it is the only reason I have a branded one.
 

·
Registered
Joined
·
233 Posts
Discussion Starter #7
It’s only powered when the car is on. It does parking mode with the battery in the dashcam unit.
 

·
Registered
Joined
·
12 Posts
If you're taking off the A-pillar trim its a good chance to do this little fix to stop the potential rattling that can happen back there:

Danny, did you reuse your clips? I've been holding off trying to fix my rattle because I thought I need to get new ones.
 

·
Registered
Joined
·
233 Posts
Discussion Starter #9
If you're taking off the A-pillar trim its a good chance to do this little fix to stop the potential rattling that can happen back there:

Danny, did you reuse your clips? I've been holding off trying to fix my rattle because I thought I need to get new ones.
I just bent mine back into shape. They are an absolute pain to get out though!
 
1 - 9 of 9 Posts
Top