Speak EV - Electric Car Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
Does anyone happen to know what I’d going on here? I can’t post a video, but the engine won’t turn on. The fuel/energy gauge moves up slowly and there is a high pitched whine that continues until I turn the car off.
if I turn it halfway off then the radio plays.
The car was absolutely fine last time I drove it about 5 days ago.
 

Attachments

·
Registered
Joined
·
5,128 Posts
Flat 12 volt. Try a jump start from another car or a few hours on a 12v charger.
 

·
Registered
Joined
·
4,441 Posts

·
Registered
Joined
·
5,128 Posts
I'm with Simon, just replace it. EVs are hard on their 12v batteries and anything over 5 years old is doing well. Do you know how old the current one is - they are usually date stamped. If you can get a jump start then Halfords can fit one, if not the RAC have a mobile service or if you can wait until Tuesday try or Tayna batteries or Post your job | Who Can Fix My Car
 

·
Registered
Joined
·
23 Posts
Discussion Starter #7
Thanks for all your replies. I looked at buying one of the suggested batteries, but wanted to get the car running and be sure, so called the AA. They charged the battery but it was showing as a weak charge with a suggestion to replace. As luck would have it they had a Bosch battery so exchanged like for like and everything seems to be great. The old battery looked like it had been in there awhile so definitely needed doing. Thanks again.
 

·
Registered
Joined
·
5,128 Posts
Glad that you are sorted and that it was a relatively low cost problem. 12v batteries have a limited life so at least you know that will not happen again for a few years.
 
1 - 8 of 8 Posts
Top