Speak EV - Electric Car Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi everyone
I've recently bought a Ford Transit 350 that was converted from new by Smith in 2011. Unfortunately I may possibly have been diddled or just unlucky, as soon after I got it it started randomly tripping the rcd on the house circuit that I charge it from. Even worse, the charging circuit (in the vehicle) has now failed altogether. Power is fine to vehicle 240v fuse box; 12v battery charging fine, main battery not doing anything.
Although I can fix most things usually and know my way around a multimeter, electric vehicles are all new to me and I lack a lot of knowledge. So failing being able to fix it myself ,does anyone know any electric vehicle specialists in the Nuneaton /Coventry /Leicester /perhaps Birmingham area?
 

·
Registered
Joined
·
39 Posts
Hi dave i have one of these vans.. was it being charged from a 32 amp socket 32 amp breaker running at least 4 mm cable...?
There is a 32 amp breaker under the passenger seat for the on board charger on mine...
 

·
Registered
Joined
·
39 Posts
Hi dave i have one of these vans.. was it being charged from a 32 amp socket 32 amp breaker running at least 4 mm cable...?
There is a 32 amp breaker under the passenger seat for the on board charger on mine...
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Mine has the breaker at the front of the driver's seat, but it sounds similar. Power is coming out of it, but I haven't yet traced where it goes from there. Probably to the black box with fans on in the engine compartment.
 
1 - 4 of 4 Posts
Top