Speak EV - Electric Car Forums banner

281 - 300 of 314 Posts

·
Registered
Joined
·
3,592 Posts
You clearly learnt a lot about EV troubleshooting from your Zoe days. ;)
Yeah - learning what fuse to pull was essential to maintain a good connection with the car. At least the pug has a quick release battery terminal ;)

even my 2000 reg pug306 cab had one (albeit a twist off) so must be a pug thing



miss that car

JJ
 

·
Registered
Joined
·
162 Posts
Interesting twist to app this morning . On refreshing it it now thinks car is a combustion engine ! I swear it's still an e208 in driveway.

Showing mpg figures and a fuel tank on main screen . and no option for remote charge or air conditioning.

They are not helping themselves with this app !!

EDIT - And it's back to how it was - blip in the matrix ?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
13 Posts
My experience so far.

I picked up the car, a GT, three weeks ago. It's in what I shall now refer to as 'Speak EV Yellow' considering how many members have picked that colour. The standard email from the garage said that handover would take an hour and a half. In these unusual times, it took half an hour probably because the finance paperwork was done the previous Monday.

The one thing that I forgot to get was the Polar Plus card from the dealer. It's not necessary to get the six months free subscription as that's done from the VIN but you can't get a charge without it. As I couldn't be bothered to return to the dealer for one, I paid £10 for Polar to send me a key fob (my preferred option) linked to my account. The price of laziness.

The only other information I got from the dealer was the service schedule and price. There is an Initial Service after a year for which I was quoted £89.99 for followed by a Standard Service every two years for £149.99 (this includes the brake fluid change). What threw me is that there is then another Initial (sic) Service in the 3rd, 5th, 7th etc. years. What have other owners been told/quoted? I vaguely remember someone giving lower costs but couldn't find the post.

I was thrown even further when I was told the car would need to come in after a month for an Inspection Service. As far as I can remember, there has been no mention of such on this site nor in Peugeot's literature. Takes me back several decades when a car would need an oil filter change after 1000 miles. Anybody else been told anything similar?

As for the car, it's still early days as it's only done 119 miles in our ownership not even enough to have tried our free Pod Point charger on it. The good news is that the GOM shows 68 miles to go giving a total for a charge of 187 miles. The caveat is that three quarters of the miles have been done by my wife doing food runs for her octogenarian isolating parents.

I've quickly got used to the reduced regeneration (even in 'B' mode) compared with my previous BMW i3 but I really hate that it creeps in Drive or Reverse.

The only other tip that I can pass on is over playing music via a USB thumb drive. The manual states 'The audio system will only play audio files with '.wav', '.wma', '.aac', '.ogg', and '.mp3' extensions between 32Kbps and 320Kbps'. Later it mentions that it only supports sampling rates up to 48kHz. I've using 24 bit '.flac' files with sampling rates up to 192kHz just fine. It makes me wonder just how much the manual is out of date/incorrect in other areas.

John
 

·
Registered
Joined
·
223 Posts
John.

You've found out more about Servicing than I have. I was only advised about the car needing to be serviced every 2 year, but, was told it did have to go in at the 12 month point. No costs offered, mainly because they didn't have any!

I wasn't offered or given a Polar Card, just a generic e-mail link to a Polar offer.

My GOM seems to provide me with exact range. Maybe it has learnt my journeys and driving style just short of 1k miles now.

My car's Grey, like me. :ROFLMAO::ROFLMAO:

I put a 128gb Sandisk mini USB full of music, that plays fine, but I don't use it so much now I am using Android Auto and Spotify.
 

·
Registered
Joined
·
13 Posts
JJ

Thanks for the screenshot. I couldn’t find that page on my iPad app but it is there on my Android phone app. I obviously need to pair my phone with the car even when I haven’t been driving it.

Who quoted the £63 to you? It sounds as if a bit of ringing round nearer service time will be necessary.

Nobody has mentioned the one month Inspection Service. Has no other owner been asked to bring their car in after a month?

My i3 was grey (dark silver) so it was time for a change.
 

·
Registered
Joined
·
3,592 Posts
1 month inspection could just be customer service

BUT we know they see it as an additional opportunity to sell you a service plan ;)

also my quote was from Bristol Cribbs Pug (where I bought it from)

also - when I had the Zoe, the first service varied between £60 and £110 so defo shop around.
I travelled 30miles for the cheapest service :) Bristol - Trowbridge

JJ
 

·
Registered
Joined
·
64 Posts
A good bit of driving done yesterday in the e208.
Wallasey, Wirral to Llandudno Golf Club. Traffic was shocking. Hot so AC on some of the way. Forgot to photograph the trip comp but think it was 3.7mpkwh. Return was via a friends in South Liverpool. Total average 4.3mpkwh.
Impressed with the performance of the car throughout...
133150
 

·
Registered
Joined
·
20 Posts
Decent enough, anything getting towards 200miles a charge is fine for pretty much any journey around UK including a coffee break xx
 

·
Registered
Joined
·
223 Posts
Anyone know who provides the sound system on this car?

I've had tinnitus for years and struggle listening to the radio in our Peugeot Partner vans. Some of my previous cars had B&O, Harmon Kardon, Meridian etc.

Driving home tonight, new phone streaming Spotify, playing some Modern R&B, I could not believe how good the cars audio system is, it's crystal clear with a fabulous bass and stereo separation. All in all I'm impressed, what do you owners think?
 

·
Registered
Joined
·
14 Posts
Does this car have a permannent internet connection with PSA servers? I imagine it does since you can remotely precondition it, right? So why some of the information only syncs when the phone is connected to the car bluetooth?
 

·
Registered
Joined
·
20 Posts
Does this car have a permannent internet connection with PSA servers? I imagine it does since you can remotely precondition it, right? So why some of the information only syncs when the phone is connected to the car bluetooth?
If that's the case does anyone know if OTA updates will happen? I know sat nav doesn't as it says to update with usb stick 🙄
 

·
Registered
Joined
·
162 Posts
Have read through all posts but not seen anyone having issue with car refusing to go into "READY" mode.

We took delivery of the car last Monday, e208GT, and on Wednesday got stuck in a Tesco car park when car refused to activate fully. I had been sitting in it listening to radio for about 10 mins with full dash on by NOT pressing brake when pressing start/stop button. Then tried to start car with foot on brake but no joy. Also saw "Economy Mode Activated " pop up briefly. After several attempts getting out of car and locking it with no joy, we gave up and walked home to get spare key in case transponder was duff. On return all fine and got home with no issues.

Jump forward to Saturday, went out for quick errand, didn't start first time in driveway but was successful 2nd time . However at shops did same thing again but 3rd time it worked but this time, on drive home, battery warning light was illuminated for whole journey. I put it on full charge at home and contacted dealer this morning followed by Peugeot Assistance. RAC popped out and checked 12V battery , which showed it fully charged. He removed positive lead from terminal to reset things. Seems to be working for the moment but not having a lot of faith.

I have done Map and Touchscreen updates as advised by the app, yes I got it working !


Obligatory photo of car


133217
 

·
Registered
Joined
·
3,592 Posts
When sat in the car with the dash on the car won’t start straight away :)

Initially I’d say it’s just the complexity of the starting

needs a long press of the button to start

short press just dash

foot on brake?

sorry I know you’ll have alll this down but I do need to cover the basics ;)

JJ
 

·
Registered
Joined
·
162 Posts
Thanks for reply.

Did all the correct procedures - foot on brake , long press on button . Everything fired up except no green READY sign therefore couldn't put it into Drive .

Got out of car , locked with fob . Waited 5 mins .

Did procedure again and still no READY light . Repeated several times , even tried with seatbelt attached then unattached . Still no joy.

Only came to life when we returned with 2nd set of keys 30 mins later when it acted as if nothing was wrong .

Will continue to monitor with fingers crossed everytime . Sometimes technology isn't always a step forward !


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
162 Posts
Everything else seemed normal .

Had same issue on Saturday and worked on 2nd button push . Think it needs an exorcism !!


Sent from my iPhone using Tapatalk
 
281 - 300 of 314 Posts
Top