Speak EV - Electric Car Forums banner
1 - 20 of 91 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hello All, first post here.

We randomly get this error message and a loss of power to the drive train, no other error lights on the dash. The battery was showing over 200 miles range and the outside temperature has been between 10 and 25 degrees C. The last time it happened we rolled to a standstill had to restart the car in order get underway again. Our dealer can't replicate the fault and has lost the error message in the car's history. Has anybody else had this happen? We don't think it's safe to drive the car but we aren't getting much help from Kia customer services.

Any thoughts gratefully received.
 

·
Registered
E-Niro 64kWh '4' since 9/20 (was Prius)
Joined
·
1,459 Posts
I never heard of this before so I just googled around and found this…..
It turns out the EPCU got replaced and it fixed the issue. (Electric Power Control Unit). Sister Hyundai car but very similar if not same systems are incorporated.

I suggest you should urgently show that thread to your dealer. The fault sounds identical to yours. Peter.

PS Just for curiosity, which version and year Eniro do you have?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Thanks Prawlin but this happens without any hard braking. It happens completely randomly and the turtle light doesn't come on. It's a 2020 eNiro 4, only 7k miles on the clock.
 

·
Registered
E-Niro 64kWh '4' since 9/20 (was Prius)
Joined
·
1,459 Posts
Thanks Prawlin but this happens without any hard braking. It happens completely randomly and the turtle light doesn't come on. It's a 2020 eNiro 4, only 7k miles on the clock.
It’s a different car, so the turtle light implementations might be different too. However, the same warning message is appearing with the same power loss isn’t it? I still think it’s worth pointing the dealership to that post as they typically haven’t a flipping clue which way to go on technology stuff like this. I’ve got the exact same car and not seen anything like this, yet! I think a fault in that EPCU module seems like a distinct possibility in your case? I sssume the EPCU is another name for the traction motor inverter?? Anyway. Good luck. I really hope you get it sorted quickly. Peter.
 

·
Registered
Kia e-Niro MY20 64 kWh - Gravity Blue
Joined
·
1,588 Posts
Hello All, first post here.

We randomly get this error message and a loss of power to the drive train, no other error lights on the dash. The battery was showing over 200 miles range and the outside temperature has been between 10 and 25 degrees C. The last time it happened we rolled to a standstill had to restart the car in order get underway again. Our dealer can't replicate the fault and has lost the error message in the car's history. Has anybody else had this happen? We don't think it's safe to drive the car but we aren't getting much help from Kia customer services.

Any thoughts gratefully received.
Next time, shoot a video, show it to the dealer and leave the car with them until they fix it. They should give you a loaner of course....
 

·
Registered
E-Niro 64kWh '4' since 9/20 (was Prius)
Joined
·
1,459 Posts
They've had for 2 weeks and have refused us a courtesy car.....
I suppose until they see actual evidence of it, or can replicate it themselves, they won’t accept responsibility of it. If it was a Toyota, they wouldn’t let you take it away until it’s fixed and you would certainly get a loan car. It isn’t Toyota however.

It does sound potentially dangerous. Especially so if it happened whilst travelling on one of our horrendous so called 'smart' motorways with literally nowhere to pull over when it suddenly stops! Is there any pattern to it? How many times has it happened? How long has it been going on? How long have you had the car? Sorry, so many questions.

I agree with @Xinix you must get video and/or screen snapshots of it. Preferably on more than one occasion of it happening. Then maybe contact Kia UK and voice your serious safety concerns along with the evidence, and a link to that other similar thread. This must be very frustrating. Good luck. Peter.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #10 ·
It's been going on since the car was about 6 months old, we bought the car new in October 2020. Completely random, no pattern to it, must have happened at least a dozen times. "Smart" motorway does bear thinking about.
 

·
Registered
Joined
·
12 Posts
Hello All, first post here.

We randomly get this error message and a loss of power to the drive train, no other error lights on the dash. The battery was showing over 200 miles range and the outside temperature has been between 10 and 25 degrees C. The last time it happened we rolled to a standstill had to restart the car in order get underway again. Our dealer can't replicate the fault and has lost the error message in the car's history. Has anybody else had this happen? We don't think it's safe to drive the car but we aren't getting much help from Kia customer services.

Any thoughts gratefully received.
Hello Peter it happened on my car
 

·
Registered
Kia e-Niro MY20 64 kWh - Gravity Blue
Joined
·
1,588 Posts
Again: drop it off at the dealer and tell them to fix it. Really people, this is an expensive piece of equipment. It should just work.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #14 ·
So, after the dealer messing about with it for 4/5 weeks (dropping out the main battery etc. etc.) someone a bit higher up the ladder at Kia technical looked at the data the dealer had collected. They have now decided to take the vehicle back to Kia themselves for further investigation. Funnily enough they sent a transporter to collect rather than driving it there.......
 

·
Registered
E-Niro 64kWh '4' since 9/20 (was Prius)
Joined
·
1,459 Posts
Looks the same, how often has it happened?
You said there was no turtle light, but there clearly is on that screenshot above. This pretty serious fault sounds virtually identical to the Hyundai linked fault to me. Have they finally issued a loan car now?

@Ber which model Eniro do you own please? How often has it happened in your case? Any more info you can give? Have you also reported it to a dealership yet? IMHO, one report of this potentially dangerous fault isn’t great, but two reports appearing is BAD!
Peter
 

·
Registered
Joined
·
12 Posts
It is Kia E NIRO 4+ .It happens almost every day and sometimes pops up a couple of times in one day. Before I left it at the dealer, the car didn't move when I was at a traffic light and I had to restart the car.
Very worried bc it is a serious safety issue.The range also dropped (full charge 190 miles)
Yes I reported it to the dealer and am waiting for a part but it may take very long. But I didn’t know which part they are changing because I didn’t speak to the the technician
Hopefully it will be sorted out.
 

·
Registered
Joined
·
12 Posts
So, after the dealer messing about with it for 4/5 weeks (dropping out the main battery etc. etc.) someone a bit higher up the ladder at Kia technical looked at the data the dealer had collected. They have now decided to take the vehicle back to Kia themselves for further investigation. Funnily enough they sent a transporter to collect rather than driving it there.......
It is Kia E NIRO 4+ .it happened every day almost sometime pop up a caple of second and disappeared sometime staying a bit long
Vary worried seriously safety issue.The rang also dropped/full charge 190 miles/
Yes I reported the dealer and waiting the part my it take very long but I didn’t know which part should be change because I didn’t speak to the the technician
Hopefully
Hello Jezpiet
Is you car problem solved?
my car happened every single drive the power limit error happened and I am so frustrated
I enquire the dealer again
 

·
Registered
Joined
·
12 Posts
So, after the dealer messing about with it for 4/5 weeks (dropping out the main battery etc. etc.) someone a bit higher up the ladder at Kia technical looked at the data the dealer had collected. They have now decided to take the vehicle back to Kia themselves for further investigation. Funnily enough they sent a transporter to collect rather than driving it there.......
Hello Jezpiet
Has your car issue been sorted out? What was the problem? The things happening to your car is similar to what is happening to mine. My car has been at the dealership for more than 3 weeks. Thanks
 
1 - 20 of 91 Posts
Top