Speak EV - Electric Car Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter #1
Had a mini Pro unit fitted. Connected it to the Juicenet app without issue but the functionality is quite poor. It's possible to see voltage and frequency, I can set a start and end time for the charge and I can manually start and stop the charge. That's all that actually works. It shows zero amperage and zero power while charging so it thinks nothing is actually going into the battery resulting in a full charge instead of calculating an end time for a target charge amount as it's supposed to. History is useless because of the zero amp issue as are all the stats screens.

Just wondering if this is a known limitation with the way the EO unit interacts with juicenet or if there's something wrong at my end!
 

·
Founder of EO Charging
Joined
·
47 Posts
Had a mini Pro unit fitted. Connected it to the Juicenet app without issue but the functionality is quite poor. It's possible to see voltage and frequency, I can set a start and end time for the charge and I can manually start and stop the charge. That's all that actually works. It shows zero amperage and zero power while charging so it thinks nothing is actually going into the battery resulting in a full charge instead of calculating an end time for a target charge amount as it's supposed to. History is useless because of the zero amp issue as are all the stats screens.

Just wondering if this is a known limitation with the way the EO unit interacts with juicenet or if there's something wrong at my end!
Good morning,

Thanks for bringing this to our attention and sorry to hear that you're having problems with your EO Mini Pro. We're keen to get this resolved for you as soon as possible, can I ask that you contact our support team on [email protected] and provide them with your product serial number.

This issue has been flagged to our support team and they are anticipating your contact this morning. If there's anything I can do to support in the meantime then please contact me here on Speak EV.

Many thanks,
Miles
 

·
Registered
Joined
·
100 Posts
Discussion Starter #4
Sorted.

Many thanks to Jack on support who identified a faulty unit, arranged for a replacement to be delivered and also arranged for the original installer to come and swap the units - all in record time.

All working as expected now :)
 
1 - 4 of 4 Posts
Top