Speak EV - Electric Car Forums banner

1 - 20 of 48 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter · #1 · (Edited)
I got a notification that due to problems with downloading maps we are being offered a free Europe map for a limited period.

However trying to find the freebie took a while, so:

Take SD card out of car and plug into computer.
Run the R-Link toolbox
Navigate to Manage the products on your R-Link and download new applications
Click on My Catalogue and then the search tab and enter "Europe Map 45 countries"
That will hopefully allow you to choose the whole of Europe at no charge. I wanted the maps but would never have paid their crazy prices so this is a handy chance to get them.

I posted this on both this and the myrenaultzoe site as I am never sure which is the most popular?
 

·
Zoe Devotee
Joined
·
9,032 Posts
First!!!!! Check you've got a bigger than 4gb TomTom card.

However if you don't, I don't recommend playing about with other bigger SD cards until someone has written an idiot proof guide.

I managed to clone a card yesterday, thought I had it all working, plugged into car and nothing. Then thinking "no biggie" I stuck my original SD back in the car and it didn't work. Strange! So I plugged it into my PC again and it said it was corrupt. (i'm no clown with computers, worked in IT for 20+ years). Seem that the Rlink software has a bug or two in it.

I got the SD working in the end but I won't publish it as I don't want anyone "having a go" and then moaning it didn't fix it. It was pretty involved.

I'll try again when I've got a decent new SD and document if successful.
 
  • Like
Reactions: yoh-there

·
Zoe Devotee
Joined
·
9,032 Posts
Lol

It's only 4gb, are you on dialup!
 

·
Zoe Devotee
Joined
·
9,032 Posts
I downloaded it in minutes. Fibre broadband my end.

Although it won't work in my car.
 
  • Like
Reactions: Fred737

·
Zoe Devotee
Joined
·
9,032 Posts
I’ve seen it writ large that it’s impossible to clone the TOMTOM SD card and make it all work. Well I can now confirm that it’s nearly true…. To clone the SD card and make it work requires a lot of to-ing and fro-ing between your PC and your Zoe.

The following guide is just that, just a guide, it can’t be considered comprehensive as I wrote it at about 3am following a Marathon 6 hour session trying many many many permutations to get to something that worked.

I updated from the standard TOMTOM 4gb card to a 8gb card (I’ve got a 16gb on order so I’ll test my guide when it arrives just for completeness sakes).

Firstly you cannot carry out this process without R-Link Explorer (kudos to the developer for making this app available). Also ***** BE WARNED ***** you will be accessing and copying data from your TOMTOM SD, you need to be very careful that you know which SD your accessing (If you destroy the data on your TOMTOM card then I can’t be held responsible)

  • FIRST End task on R-Link Toolbox (this must not be running when you are working with R-Link Explorer)
  • Load R-Link Explorer Format Spare SD (there is a menu option to build a generic TOMTOM card, do not have your actual TOMTOM card connected to your PC to reduce risk)
  • Rlink Explorer to build a new TomTom SD
  • Stick the card in your car (updates something, not sure what but it’s necessary or R-link toolbox reports your new SD as corrupted)
  • Eject SD card (going through safely remove process in car) then plug back in PC, Use R-Link Explorer and copy contents of original card to new card.(make sure your copying from the correct source to correct destination, don’t make the mistake of wiping your genuine TOMTOM card)
  • Sync with rlink site, manage your products and uncheck your current map and sync. You'll note you see all the capacity, don't get too excited just yet.

  • Check R-Link Toolbox settings and make sure the backup option is switched on.
  • Update rlink toolbox to do a backup of update, run update.
  • Put SD card in car again. This will carry out an update, and reboot. No maps will be found because you’ve not installed any, but you should find your R-Link apps are working (Aquarium etc) Your SD card is now semi virgin with everything working except maps. You'll also note your SD card size has shrunk, this is peculiarity of TomTom, we will fix it below.


  • Rlink Explorer, run File System check on your new SD card. This bit is key, if you don't do it then it won't let you resize your SD card
.

  • After the file system check you need to expand the SD and delete the later TomTom.00x files. Delete TomTom.003 and TomTom.004. You'll need this space to expand the TomTom.000 volume.
  • Then expand the SD card in the left pane, click on TOMTOM.000 then go to the menu to resize TOMTOM.000 partition up to 6500mb (big enough) @andyfras has found that this may not be sufficient space (worked for me but not for him) so I suggest you try at least 6500mb but more if you can spare it within reason. 8000mb or 8500mb should be sufficient for multiple maps.

  • Car again, update. Virgin with bigger TomTom size (all this updating seems to push the SD card capacity up via Rlink to Renault and then works in R-Link website, doesn’t happen instantly though)
  • PC again. Install GB map first, press Sync.

  • Car again and install SD. This updates and everything works as a perfect clone. (finally) :cool:
  • Back to PC, hopefully the R-Link web site now sees extra capacity and allows Europe map install. Then load up rlink tool box and wait while it does a backup and sync.

  • Card in car, updates, and restarts.
  • Reboots and loads maps and 1 more update.
  • Finally you have to go into Navigation - Settings - Switch Maps. et voila (last bit courtesy of @andyfras)
· You should now have UK maps and Europe 45 maps installed. It’s a very eclectic build process.

I can also confirm that my R-link runs smoother than before, my guess is the original TomTom SD is no more than a Class 4 card so switching up to an ok brand (hama £6) Class 10 allows for speedier load times.
 

·
Zoe Devotee
Joined
·
9,032 Posts
Its the whole Europe 45 maps, including UK. Should be bang up to date.
 

·
Zoe Devotee
Joined
·
9,032 Posts
Instructions might be a bit flakey. It was 3am when I finished with my cars so pretty tired.

I will test again when my 16GB arrives. The main point is at a lot of steps you need to plug into car and there is clearly something going in with rlink updating a server that feeds the rlink site.
 

·
Registered
Corsa-e Elite Nav 70 reg
Joined
·
675 Posts
Excellent work Sandy. Unfortunately I failed at the resizing stage. It says:

resize2fs 1.41.14 (22-Dec-2010) open: Permission denied while opening E:/TOMTOM.000


I've tried other sizes, but it's always the same message. My PC has Win10 32bit, R-Link Explorer 1.2.2 - 8GB card.

I've tried running as administrator, and on another PC (running XP)
 

·
Zoe Devotee
Joined
·
9,032 Posts
Do you have TomTom.004 and onwards? Delete them. You only need .000, 001, .002, maybe 003
 

·
Zoe Devotee
Joined
·
9,032 Posts
Try file menu and open file and open the TomTom.000 file so it expands ext01 into the right pane then try extending the partition size.
 

·
Registered
Corsa-e Elite Nav 70 reg
Joined
·
675 Posts
When I tried that, it said that files needed to be closed first.

This time when I ran resize, I got the following message:

Extend files (or partition) on E:/TOMTOM.000
resize2fs 1.41.14 (22-Dec-2010)

to 1664000 (4k) blocks.


Please run 'e2fsck -f E:/TOMTOM.000' first.
 

·
Zoe Devotee
Joined
·
9,032 Posts
I think that's the file system check, same menu as resize? Give it a go?
 

·
Registered
Corsa-e Elite Nav 70 reg
Joined
·
675 Posts
Thanks Sandy, that fixed it, although 000, 001, 002, and 003 still show as 2, 2, 2 and 1.39GB respectively after resizing.

I'm in the process of syncing the original GB maps now (about 30 minutes).
 

·
Zoe Devotee
Joined
·
9,032 Posts
woo hoo. :) Yeah they show funny until after you plug in car, and it seems to cloud sync back to Renault that you've got a bigger card. Then when you update maps in rlink website you'll see you have more space.

The TomTom.000 .001 .002 seem to be spanned volumes in some way.
 

·
Registered
Corsa-e Elite Nav 70 reg
Joined
·
675 Posts
I finally reached the end of the process, but there's no sign of the new maps on the card. The card just shows UK + ROI, both in the car and R-Link Explorer. I've tried resyncing in the R-Link Store (where the Europe maps are shown as syncable), but still the same result.
 
1 - 20 of 48 Posts
Top