Speak EV - Electric Car Forums banner

1 - 20 of 25 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Hi, for the last couple of days I've been getting a message saying that the front camera is blocked. Does anyone know where the front camera is situated? For the life of me I can't find it. Thanks Michel
 

·
Premium Member
2020 Corsa E
Joined
·
7,583 Posts
They're usually attached to the rear view mirror looking forward out of a swept area of the windscreen.
 

·
Registered
Joined
·
167 Posts
I think if you look at your windscreen from the outside you can see it at the top of the windscreen in the middle.

I’ve noticed low winter sun can trigger that warning.
 

·
Registered
Joined
·
3,769 Posts
I’ve noticed low winter sun can trigger that warning.
I have witnessed the very same thing on about two occasions.
The first time it happened, was when we where travelling along and there was a massive black cloud in the sky.
Then all of a sudden, there was a gap in the cloud and brilliant sun shine hit the front of the car head on !.
Instantly we received the warning on the dash panel and the usual “Bong” !.
After a few seconds it cleared the warning !.
I think the sudden burst of strong sun, just caught the camera out napping !.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #5
Thanks for the help. I think you are right the low sun seems to affect it. Cheers Michel
 

·
Registered
Joined
·
225 Posts
My wife had this message constantly for about 10 miles, when driving in the dark on a dry but mirky night last week. I suspect it was a patch of water on the windscreen in the area of the camera (behind the rear-view mirror). I drove the car home and used the windscreen wipers before we set off - no more message.
 

·
Registered
Joined
·
261 Posts
I used to get this all the time for the first 300 miles. Now it does not do it at all. I think for the first few hundred miles the camera calibrates.
 

·
Registered
Joined
·
1 Posts
Had this issue for the first time today, weather has been sub zero overnight. The windscreen directly in front of the camera (within sealed unit) has been fogged up anyone else had this problem?
 

·
Registered
Joined
·
90 Posts
Yes I have had the problem of camera blocked message tonight. I am also experiencing excessive interior moisture on the windows and I suspect this maybe causing the problem . I will have a good look tomorrow in daylight.

I also experienced non engagement of the cruise control and could not see why until I noticed the tailgate was not fully closed. Page 188 of the manual states that any open door or tailgate inhibits the ACC.....Chinese logic??
 

·
Registered
Joined
·
3,769 Posts
T
Yes I have had the problem of camera blocked message tonight. I am also experiencing excessive interior moisture on the windows and I suspect this maybe causing the problem . I will have a good look tomorrow in daylight.

I also experienced non engagement of the cruise control and could not see why until I noticed the tailgate was not fully closed. Page 188 of the manual states that any open door or tailgate inhibits the ACC.....Chinese logic??
The problem with the ACC, could that not also be related to the camera also ?.
Just a thought !.
 

·
Zoe Devotee
Joined
·
8,947 Posts
Page 188 of the manual states that any open door or tailgate inhibits the ACC.....Chinese logic??
Maybe MG, quite rightly, assume your too stoopid to use ACC if you can't even shut all the doors before driving off?
 
  • Like
Reactions: finchlean

·
Registered
Joined
·
90 Posts
T

The problem with the ACC, could that not also be related to the camera also ?.
Just a thought !.
Good point but the ACC non engagement did not occurr on the same trip and lane control, which uses the camera, worked ok when the ACC did not engage.
The tailgate looked closed on the outside but had obiviously not completely locked and the door warning light was not on . I only noticed the tailgate being sensed open whrn the car power was recycled and it did the system scan.

The odd point is why did the system not keep bonging that the tailgate was not completely closed?....I suppose there could be an occassion when the tailgate is deliberately open when carrying a long load perhaps .
 

·
Registered
Joined
·
90 Posts
There is only one forward camera mounted on the inside of the windscreen in front of the mirror. If this looses vision due any form of windscreen contamination a warning is locked into the system and displays on the drivers display.

I had the problem the other day due to frost but even when it was clear the fault remained until the power was switched off and on again when it then cleared the fault

Is it normal that the blocked camera fault will not clear unless power is recycled?
 

·
Registered
MG EZS 2020
Joined
·
4,861 Posts
If this looses vision due any form of windscreen contamination
Yep, even bright sunlight. Out in the very bright low sun earlier this week and the camera warnings were coming thick and fast.
 
  • Like
Reactions: Carty

·
Registered
MG EZS 2020
Joined
·
4,861 Posts

·
Registered
Joined
·
3,769 Posts
Yep, even bright sunlight. Out in the very bright low sun earlier this week and the camera warnings were coming thick and fast.
Yeah - I have received the "Camera Not Available" warning on a few occasions in the summer months mainly, it usually coincide's instantly when the sun suddenly pop's from behind a cloud and the sun hits the front windscreen head on.
After a short while the warning disappears from the dash panel.
I have had the car almost 11 months now and I have only seen this warning maybe 3 or 4 times in that time frame.
Bit off topic ( sorry ) but the one I see more regularly is the info unit performing the "Black Screen Of Death".
This I witness about once every 6 weeks or so.
I always have the radio on a low volume setting in the car just for back ground music.
At no given time, the screen will just turn completely black.
Some times the music will still be playing in the back ground and the coloured screen will return after a few minutes, other times it will not return until the car is powered down and rebooted.
On about two occasions, the head unit has completely fallen on its arse and shut down and rebooted itself, displaying the MG sign on the info screen.
No big deal, but once I was using the Sat Nav to guide us home and the screen turned black.
It was still giving spoken directions, but no map on the screen.
This was a bit of pain at the time.
Pulled to the side of the road and rebooted the car completely, the info unit / Sat Nav restored itself straight away.
I believe a few owners have had an update applied to the head unit via a USB stick at the dealership ?.
Maybe this will clear the "Bug" in the system.
 

·
Registered
Joined
·
43 Posts
Doesn't the ACC use the radar? AFAIK it's only cheap ACC systems that use the camera.
'proper' autonomous drive systems use multiple LIDAR heads and camera's. For the price of the MG what we get is a pretty good deal. You'd not rely on it, but good as an assist. Tesla now charge an extra $10k option price for theirs now.
 

·
Registered
MG EZS 2020
Joined
·
4,861 Posts
You'd not rely on it, but good as an assist
Oh I don't know. I use MGPilot quite a lot and am extremely happy with it. It excels in traffic jams.
 
1 - 20 of 25 Posts
Top