Speak EV - Electric Car Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Hi,
The R-Link 1 on our 2014 Zoe is showing a lit up white screen and nothing else.
The sound system is still working and can adjust volume and change radio channels and media from the steering wheel controls, but can see no menus or anything on the screen.

Have tried rebooting the R-Link, pulled the fuse, and the problem is still there. We really are at loss what to do now, and would appreciate any advice on what to try, or what might be wrong with it.

Want to avoid putting it into the dealer, if we can, as not under any warranty. I know we should have taken extended warranty, but got expiry dates mixed up, and were too late to get it.

Anyway, any advice is greatly appreciated.
Thanks
Duncan
 

·
Premium Member
2020 Corsa E
Joined
·
7,582 Posts
What happens if you take the SD card out?

I think it's probably going to need a trip to a specialist unfortunately. HEVRA approved garages are a lot cheaper than main dealers though.
 

·
Premium Member
2020 Corsa E
Joined
·
7,582 Posts
If disconnecting the 12v for a bit doesn't work then I think it is a garage job unfortunately.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #6
Just a bit of an update-
I disconnected the 12v negative for an hour or so. Same problem still exists.
Guess I'll be need to save my pennies, and put it to a garage.

Does anyone know of anywhere who deal in used Zoe parts? Like an online scrap dealer for Zoes. Or even whether the R-Link 1 can be swapped out by the user, with an R-link1 or R-Link 2, or would programming by the dealer need to be done?

Thanks

Just a thought.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #8
Am jumping back on this thread after a while.
I'm really at a loss. Have tried the battery disconnect overnight as suggested. No joy, still the same issue.

I'm reluctant to go to the dealer without some idea of what the actual issue, or a ball park idea of what it might cost, just don't want to get fleeced.

Don't laugh, but we have been using an android tablet just the right size mounted over the rlink as a temporary fix till we can get a solution. With a car front end installed on the tablet it gives us mph, internet radio, music, navigation, zap map but obviously can't give us any specific Zoe functions. That said, it has been useable. As we have a rear view mirror reversing camera, we still have that working.

With all that said, we'd still like try to find a solution for the problem, and I'd really appreciate any further advice anyone could give us.
Thanks
Duncan
 

·
Registered
Joined
·
1,178 Posts
I suspect the dealer will just suggest replacing the R link, Duncan. (Megabucks.) I'd just continue with your ingenious substitute.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #10
We can certainly run with that, as it gives us good functionality and actually done stuff we don't get with the rlink.

All I'm concerned about is that I don't think it's ever had the BMS update, and if needs it going forward, can it be done without access to the rlink. We actually find the Android tablet better to use.
140549
 

Attachments

·
Registered
Joined
·
1,178 Posts
Regarding the BMS update, I think you'd be paying more to have the r link replaced than the update is worth. Don't concern yourself IIWY.
 

·
Registered
Renault Zoé ZE50 (on order)
Joined
·
33 Posts
I'd strip the thing down and reseat all ribbon cables etc. If that doesn't work the display controller pulled its lip over its head and swallowed and you'll need to find a board from a wreck or a model that took a knife to the display or something.
 

·
Co-author of CanZE. Q210 nov 2013
Joined
·
4,541 Posts
Bummer. But the dealer doesn't need R-Link to do any updates, so no worries there.

The unit itself is really easy to replace, so if you can find a second hand replacement, it's quite the no-brainer.
 
1 - 13 of 13 Posts
Top