Speak EV - Electric Car Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I've had my e-Niro for around a month now, but cannot seem to get LIVE traffic updates on the SatNav. UVO is working fine, and I have "activated" Kia LIVE ([SETTINGS] > [Data/Network] > [Kia LIVE] > [Information sharing notice] then press "activate") and I appear to get weather icons if I zoom out on the map (indicating, I presume, a "live" connection) but still I get NO live traffic data in the SatNav. I have heard that I need to tether to a Wi-Fi hotspot via my phone (I don't believe I should have to) but even that I cannot try, as I have no Wi-Fi option when selecting Data/Network. Anyone have any ideas what I might be doing wrong, or how I can activate live traffic data when using the Kia SatNav?
 

·
Registered
Joined
·
321 Posts
They probably forgot to register the head unit Device ID with TomTom (who provide the live traffic and speed camera data). Have a word with Kia customer services 0333 202 2990 who should be able to get it registered for you.

If your car has the app you don't need to connect to a wifi hotspot for traffic since your car can already access T'internet through the cars SIM!

Hope this helps

John.
 
  • Like
Reactions: AndyPearson

·
Registered
Joined
·
593 Posts
I've had my e-Niro for around a month now, but cannot seem to get LIVE traffic updates on the SatNav. UVO is working fine, and I have "activated" Kia LIVE ([SETTINGS] > [Data/Network] > [Kia LIVE] > [Information sharing notice] then press "activate") and I appear to get weather icons if I zoom out on the map (indicating, I presume, a "live" connection) but still I get NO live traffic data in the SatNav. I have heard that I need to tether to a Wi-Fi hotspot via my phone (I don't believe I should have to) but even that I cannot try, as I have no Wi-Fi option when selecting Data/Network. Anyone have any ideas what I might be doing wrong, or how I can activate live traffic data when using the Kia SatNav?
If you are getting live weather and charging station info, then it’s unlikely it’s a registration issue.

I notice on BlueLink (which shares common code with Kia UVO) that the traffic info is a bit hit and miss. I don’t live in a major urban area so I often see nothing at all in the traffic list. It might be just that...
 
1 - 3 of 3 Posts
Top