Speak EV - Electric Car Forums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
54 Posts
Easier than you think, on the myenergi app I set it to eco++ and then scroll down to boost and select scheduled. Tap the plus button at set it from 00:30 duration 4 hours ok it, your done! 😊. The boost setting goes into fast mode too gaining all that lovely 5p an hour.
 

Attachments

·
Registered
Joined
·
181 Posts
I tried a few third party apps but found them unreliable or annoying for scheduling charging.

My solution is as follows:

  1. Use the car's "scheduled start time" feature to set a 0.30am start time.
  2. Work out how much energy your car can consume in the 4hr off-peak period
    1. This will depend on your battery capacity and charging speed
    2. Performance M3 at 10A is about 10% every 4hrs
  3. Set your car max charge limit to the current battery percentage + 10% (or whatever your % is)
In addition to the above, I have a "Remote for Tesla" app automation set up using iPhone shortcuts to stop charging at 4.30am. The combination of these two approaches has only resulted in me going into standard rate electric once.
 

·
Registered
Joined
·
1,374 Posts
Depends how technical you want to get. A few things have changed over time, Tesla introduced a wake car command whereas just firing a ‘stop charging’ command at the car doesn’t seem to wake the car if it was asleep, as a result a lot of the apps can be hit and miss, working fine when the car is awake, failing when not. Tesla have also introduced a captcha when getting a token which makes generating one harder.

Fir my own purposes I pretty much solved both problems but others can use them. I don’t keep your details making it as secure as I can, you can use your own token or I can create one, and ive a simple api (basically a web page url) that can be called from anywhere or from a app,e shortcut which handles the wake up as well as command. And it’s free

 

·
Registered
2022 Tesla Model 3LR
Joined
·
1,661 Posts
Zappi in eco++
Scheduled boost set to 00:30-04:30 Monday-Sunday
Plug in whenever you need a top up and it’ll only charge during those off peak hours. You’ll get around 25-26kwh so on my tesla SR+ that’s about 50% charge

if you need more you can go to the myenergi app and switch to fast to charge immediately (also can do that on the charger control panel directly)
 

·
Registered
2022 Tesla Model 3LR
Joined
·
1,661 Posts
Plus if you have solar the car will top up during the day only then kick in during the off peak hours if required.
I’ve given up on that - my panels are only 2.5kw so rarely give enough. And with octopus off peak being 1/3 the cost of peak you need the %green to be pretty high to make it worth it. But if you can generate more (you’d want 1kw minimum sustained for a few hours at 75% green) then definitely worth it
 

·
Registered
2022 Tesla Model 3LR
Joined
·
1,661 Posts
Strange this thread has so many replies.

Use the car's "scheduled start time" feature to set a 00:30 start time.

That's what I do and have done for the past 2 years, easy and it works.
and if you need more than 4 hours charging you’ll be charging partly at peak prices. Which is fine - if that works for you and you need the charge. But others may want to restrict to the off peak hours and there is no simple way to do that in the car.

limit to specific offpeak hours but have additional requirements
  • use a smart charger with scheduling like a zappi 2 (my preference)
  • use an app like teslafi to turn on/off charging on the car. works with most (all?) chargers but requires a small subscription payment for the app

Workarounds
- use ‘start charging’ in the car and adjust your desired charge limit in the app based on current charge and how much charge you’ll get from 4 hours at 7kw to stop before the peak period. Eg 28kwh, aroud 50% in an SR+, 30% in a LR/P?

Don’t care if it goes outside of offpeak
- use start charging in the car and leave your charge limit as it normally is
 

·
Registered
Joined
·
96 Posts
A strange thing happened last night. My timed charge started and finished an hour later than normal. My hub's settings have not changed. Anyone else get this?
If you are using a Zappi charger check the time on the front screen of the charger, most are apparently one hour out this week, including mine. Seems they have ended BST a week early :D
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top