Speak EV - Electric Car Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Hi

I think I might have seen someone facing a similar issue, so sorry if I am raising something that is already discussed, however I could do with some opinions on this reasonably quickly.

My infotainment system blacked out as we were driving. It was raining and it takes the heater out with it too (or at least mine did) so that although the fan was blowing, it was only cold air. No pushing of buttons resurrected it, nor did stopping the car and turning it off. About 5 mins later, possibly longer, it came back on (as we were driving). At this point, so did the heater and all the bongs that come with starting the car for the first time.

I flagged this to the dealership and they booked me in. Since then, it did it again as we were driving with exactly the same symptoms etc.

So today it went in and they did (their words) a "software update" as they said this had happened to others and the update fixes it. Thing is, it isn't the new update that everyone is talking about - bongs still there, no remaining mileage on the dash and the radio at full pelt when you get in.

Question: Is it common for this to happen and have others had it resolved via the (hush-bong) update?

I was surprised that, if they were "applying an update" that it wasn't the current update. Looks like they re-flashed the old one???? I was told if it doesn't sort it, then they will change the entire unit.
 

·
Registered
Joined
·
68 Posts
My infotainment blacked out on startup along with multiple warnings including hill decent, acc, no lane assist etc. and a clicking sound from the speakers along with no sound from the turn signals, although the indicators worked.

Brought it to the dealer who connected it to laptop. After two attempts he was able to clear the faults one by one, which showed up as red on the block diagram and then turned to green as they cleared. He could not explain the problem and it has not recurred. (Happened 2 weeks ago). A member of another forum reported the exact same problem however they have not responded to my question as to how their faults were resolved.

Hope it does not happen again. Going to leave it for a month before I have comfort pack update.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
Thanks. They did not mention the comfort pack but just said software update, so I assumed it would be the latest. I haven't driven it since I drove back but will drive it tomorrow. It happened twice in the last 4 journeys,so I may have to do a few trips first.

If you do find out from the other forum and have the time, I'd be interested to know what they said. Thank you again.
 

·
Registered
Joined
·
3,714 Posts
I think I posted this problem on my car about 4 weeks after taking delivery in Jan 2020.
First time the info screen when totally black, but the music a was still playing.
About five minutes latter, the same thing happened again, but this time the entire info unit just completely shut down, and commenced a complete reboot !.
After posting this problem, other members reported similar issues.
I reported the problem to the supplying dealer and urged other owners to do likewise.
Strangely, it has only blacked out the screen once more since the two original issues in almost 7 months.
I will wait for any updates to be performed until the car is due its first service.
 

·
Registered
MG EZS 2020
Joined
·
4,645 Posts
A couple of days ago I've had the infotainment front screen showing over the reversing camera. Didn't obliterate the view as the infotainment front was opaque, but it made it awkward to see and was a bit disconcerting. It did it twice on the same day. It hasn't happened again since.
 
  • Like
Reactions: Carty

·
Registered
Joined
·
3,714 Posts
A couple of days ago I've had the infotainment front screen showing over the reversing camera. Didn't obliterate the view as the infotainment front was opaque, but it made it awkward to see and was a bit disconcerting. It did it twice on the same day. It hasn't happened again since.
Sorry, have you had the the "Comfort Upgrade" done on your car Neil ?.
 

·
Registered
MG EZS 2020
Joined
·
4,645 Posts
Sorry, have you had the the "Comfort Upgrade" done on your car Neil ?.
Yep, a few weeks ago. The thing with the reversing camera only happened the once. I know I said twice, but it was 'put it in reverse, see weirdness on screen, put into neutral, back into reverse, see same weirdness again. As I was reversing only a few feet (on my drive) I ignored it and it hasn't happened again since (crosses fingers).
 
  • Like
Reactions: Carty

·
Registered
Joined
·
3,714 Posts
Yep, a few weeks ago. The thing with the reversing camera only happened the once. I know I said twice, but it was 'put it in reverse, see weirdness on screen, put into neutral, back into reverse, see same weirdness again. As I was reversing only a few feet (on my drive) I ignored it and it hasn't happened again since (crosses fingers).
The reason I asked is, I though the Comfort Update included a info update also.
This has not fixed the bug in the info system then !.
Pants !
 

·
Registered
Joined
·
2 Posts
Mine went blank and started having an issue on the 1 day I needed the screen. I was trying to call my Boss on the handsfree and it basically went blank on finishing the call (I was using android Auto).
It wouldn't recover no matter what button I pressed, however I got it back by holding home button down for 10seconds, releasing it then pressing it once. This reset the Screen back to a usable state.

I did find my error also resulted in the phone menu appearing as if it was in a call with "10000000" as a number. Which only fixed when dialing a call and the other party hanging up.
 

·
Registered
Joined
·
3,714 Posts
Yeah - I had the “Black Screen Of Death” appear yesterday on a trip home from Harlech in Wales.
Travelling along nicely with the radio playing and the Nav directing us back home.
Then completely out of the blue, BOOM !.
The screen goes completely black.
Radio still playing and the Nav still reporting directions in audio only.
Screen, totally gone !.
We have had the car since the 6th January and it has done this about 4 times now.
Once it blanked out the screen ( like yesterday ) and once it fell on its arse and shut down and rebooted itself.
I think the black screen affect is somewhere between the two.
If it just fully rebooted, it would be a little better in some way ?.
Yes, I could have pulled over and powered down the car completely and then restarted it again, this would have resolved it straight away, but a bit of a pain if you are travelling across the mountains in Wales trying to avoid the sheep !.
Them “Bugs” like to pop up there head from time to time in the ZS EV.
Loved the drive to Harlech and back, scenery is beautiful !.
The car drove brilliantly, I have done the trip in an ICE car, but it’s NOT the same as in an EV !.
 

·
Registered
Joined
·
2 Posts
Them “Bugs” like to pop up there head from time to time in the ZS EV.
If it occurs again, try holding the button in the volume dial down for at least 10 seconds. Wait 2, then press once. It should power it down and do a full reboot from the MG logo. That worked for me to keep it going.... A shame mine kept happening with repeated the calls I was making (it was the phone/Bluetooth module that was stuck). Car off resolved it.
 
1 - 11 of 11 Posts
Top