Speak EV - Electric Car Forums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hello- first post. Apologies if this has been discussed before but couldn’t find anything.

I have covered 7k in just over 3 months and love it. And then today, all the drivers conveniences (smart cruise, lane keep, front collision avoidance, high beam assist and driver fatigue) all fail. I’ve included a picture below. Anyone have any idea of a quick fix - need to drive 250 miles tomorrow. Cheers
Speedometer Motor vehicle Car Gauge Steering part
 

·
Registered
Joined
·
41 Posts
As a new owner I have absolutely no technical expertise, but there is one thing you could try that cannot do any harm. Take a 10mm spanner and disconnect the negative cable from the 12 volt battery under the bonnet. Leave it off for 20 minutes, reconnect and see how you go.

This is just a stab in the dark. Good luck.

PS There might also be a fuse that is common to all those items. Worth a check.
 

·
Registered
Joined
·
5 Posts
I have a 21-plate facelift model that had a similar problem when I first got the car. Took it into the dealer and they said the front facing camera failed. It took several weeks to get a replacement and it cost £2,500 to replace, fortunately under warranty. I was able to safely drive the vehicle while waiting for the replacement.

I hope it's not the same problem with yours.
 

·
Registered
Joined
·
2,045 Posts
As suggested above. 12V Battery disconnect. It's fixed things for me before.

The camera may have failed but most likely just needs a reset. If it has failed you can still drive the car safely, just without the assistance features.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Thanks for the above advice- disconnecting the 12v battery didn’t solve it I’m afraid. I’ll try and get it into the garage in the next couple of days. I do miss all the automatic features!
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #11 ·
Hello. I’m afraid the car is still in the garage and won’t be looked at till next week. I’ll update this thread with the diagnosis
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #13 ·
Just had the diagnosis-camera needs replacing. Disappointing on such a new car- and obviously not an isolated problem from some of the comments above.
 

·
Registered
Joined
·
4 Posts
Yep, just had mine diagnosed as needing a new camera. Apparently this is the camera in the windscreen (not even sure why I have this).
 

·
Registered
Joined
·
4 Posts
Lane keep assist, lane follow assist, traffic sign recognition, and also partially used in conjunction with the radar sensor for smart cruise control, and AEBS.
Thanks, yes, that occurred to me shortly after posting. I did notice that the traffic sign recognition still works with an apparently dodgy front camera though.
 
1 - 17 of 17 Posts
Top