Speak EV - Electric Car Forums banner

1 - 6 of 6 Posts

·
Co-author of CanZE. Q210 nov 2013
Joined
·
4,279 Posts
Discussion Starter #1
As a lot of you have probably noticed, we rolled out a new version of CanZE. I am particularly excited about a new, optional (and yet unproven!!) feature that might make far better use of the ELM dongles and might (MIGHT!!) even run on the crappiest of dongles; I ordered a 2 quid one for kicks, but of course it will take weeks to arrive. Anyway, I would like to ask if some of you can set "Use ISOTP frames" in the settings and check if things run faster (especially in screens like Consumption), and/or more reliably. The dreaded ATMA errors should be gone.

If this proves to be a positive experience I am considering switching that option automatically on for ELM based dongles in the next release.

Note: In case you have build the CanSee dongle, you can use said option too, but it is faster with this setting off.
 

·
Registered
Joined
·
387 Posts
Hi @yoh-there I tried e-mailing your support e-mail listed in the play store (won't list it so the spam crawlers don't find it)... got:

Diagnostic-Code: smtp; 554 5.7.1 Mail appears to be unsolicited

Anyway this was all I was going to put:

"Hi,

Longtime no speak. Just testing out the ISO TP mode as requested. Looks faster but getting some odd response quirks between the 2.

Simplest one to demonstrate is differences between dongle test. Non ISO TP succeeds.. With ISO TP on I get error in test suite. I tried multiple times.

I'm sat in the car in a car park at the moment but I can launch a github issue later if you prefer (and this isn't already a known issue)?

Kind Regards,
Matthew"


I first noticed something was up when I found certain values weren't available in ISO TP mode but were in the other.
 

·
Co-author of CanZE. Q210 nov 2013
Joined
·
4,279 Posts
Discussion Starter #5
Well, if you have Android Studio, feel free to pull the repository and fool around. I think I fixed everything (yeah, lots of fields missing, oops), in both modes.

O.T. but the really nasty issue at this moment is sending long (multiframe) ISOTP messages over crappy dongles. But I might get to that tomorrow....
O.T. of O.T. .... but yesterday I got a crappy < 2 quid dongle running using ISOTP only mode. Will post on the CanZE bog about that soon.
 
1 - 6 of 6 Posts
Top