Speak EV - Electric Car Forums banner

1 - 20 of 53 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hello first time ever joining a forum, I've had my Mg EV for 2 months now and can only charge at a charge station, my granny plug doesn't work at all spoke to mg and they took it in and it works at there place, they say its probably a weak power connection in my home, given up on that.
Chargmaster came and changed my type one charger to a type 2, 7.4kw charger, plugged it in and the car says plugged in but not charging, the car went back to the garage twice to be checked everything fine. Chargemaster changed the unit same problem. After trying to resolve the problem with chargmaster and getting nowhere I gave up, purchased another charger from sync ev, they fitted it this morning plugged in working fine, fitter leaves, after charging 7 percent the same thing happens, the charger is tring to charge and its a start stop start stop on the unit no charge, spoken to sync ev they are looking in to it, spoke to Mg they haven't got a clue, help anyone help.
 

·
Registered
Joined
·
873 Posts
If you have any power line wifi extenders in the house - try removing them; a number of people have found they upset the MG charging at home...
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
Will do when my wife gets back at 6pm, the sync ev wall charger isn't connected to the Internet yet he couldn't connect, someone else is coming to do it.
 

·
Registered
Joined
·
2,157 Posts
Are you testing them all in the same place, e.g. the garage, so it's the power supply to that place that could be the problem? I couldn't charge my ZOE with a granny cable in the garage, but it worked fine if plugged in through the dining room window (much closer to the main consumer unit).
 

·
Registered
Joined
·
19 Posts
Discussion Starter #7
I'm not worried about the granny plug that will take too long to charge, I want my 7kw charger to work, fed up with going to the charge station for an hour to charge my car. Wish I had bought a hybrid. Never had this problem with my outlander
 

·
Registered
Joined
·
152 Posts
Is the public charger you’re using a rapid charger?

If it is, have you tried using a public 7kW charger to see if your car will charge on that? If it doesn’t there’s an issue with the AC charger on your car.
 

·
Registered
Joined
·
2 Posts
Hello first time ever joining a forum, I've had my Mg EV for 2 months now and can only charge at a charge station, my granny plug doesn't work at all spoke to mg and they took it in and it works at there place, they say its probably a weak power connection in my home, given up on that.
Chargmaster came and changed my type one charger to a type 2, 7.4kw charger, plugged it in and the car says plugged in but not charging, the car went back to the garage twice to be checked everything fine. Chargemaster changed the unit same problem. After trying to resolve the problem with chargmaster and getting nowhere I gave up, purchased another charger from sync ev, they fitted it this morning plugged in working fine, fitter leaves, after charging 7 percent the same thing happens, the charger is tring to charge and its a start stop start stop on the unit no charge, spoken to sync ev they are looking in to it, spoke to Mg they haven't got a clue, help anyone help.
Hi Alfonso4, ask your dealer to chech the onboard battery charger. I had the same issue I could only charge from fast charge points. Your granny lead and standard charger won,t work. Also ask for the software update. MG are aware of faulty onboard chargers putting the car in sleep mode and not waking. The granny lead will show two lights but if the green is flashing it is waiting for the car. If it slowly pulses then it putting a charge in. Your MG dealer may need to know this, mine didn,t and told me the car was charging when it was still faulty. All mended now though...
 

·
Registered
Joined
·
19 Posts
Discussion Starter #13
Is the public charger you’re using a rapid charger?

If it is, have you tried using a public 7kW charger to see if your car will charge on that? If it doesn’t there’s an issue with the AC charger on your car.
Works on the public charger
 

·
Registered
Joined
·
19 Posts
Discussion Starter #14
Hi Alfonso4, ask your dealer to chech the onboard battery charger. I had the same issue I could only charge from fast charge points. Your granny lead and standard charger won,t work. Also ask for the software update. MG are aware of faulty onboard chargers putting the car in sleep mode and not waking. The granny lead will show two lights but if the green is flashing it is waiting for the car. If it slowly pulses then it putting a charge in. Your MG dealer may need to know this, mine didn,t and told me the car was charging when it was still faulty. All mended now though...
Thanks just spoke to mg he thinks your suggestion makes sense he is looking into it.
 

·
Registered
Joined
·
3,491 Posts
Works on the public charger
Bit confused ( not hard in my case ) but I though a 7kw A/C public post and your Home A/C 7 kw is the same thing ?.
Assuming your wall box is in fact a 7kw unit of course ?.
So, if it works fine at the A/C public charging unit AND the dealers wall box, then does this point towards a problem at the house then ???.
I am scratching my head ( saw dust alert ) how it could be the software in the car at fault ?.
Could somebody please educate me if my understanding is incorrect folks.
 

·
Registered
Joined
·
295 Posts
I’ve tried to charge my daughter’s car on the granny lead without success and she’s tried to charge it on a 7kw public charger, both without success.

Neither of us have locked the car though whilst trying.

It’s going back to the dealer because the radio display just shows “initialising”. I’ll ask the question whilst I’m there.
 
1 - 20 of 53 Posts
Top