Speak EV - Electric Car Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
425 Posts
Discussion Starter #1 (Edited)
Have a strange issue where R-Link isn't showing the girlfriend as a contact anymore.. but it's showing all the others okay and claims it's syncing correctly. It's like it's purposefully leaving her out.

I tried removing my phone from the Bluetooth devices list and then re-adding it and I watched it download the contacts again and populate them but the girlfriend is still missing. Also what prompted me to look into this was the SatNav has also refused to give voice instructions again (no it's not the volume), so I did the 5 x Home button mash to force it to reboot but still both issues remain. I find if I leave it a day that issue normally sorts itself (TomTom activation server issue perhaps?)

Checked R-Link store and there's no update to the firmware, I'm still on the latest.

The girlfriend got impatient with the car taking a while to finish charging on 99% the other day.. Have told her the car still refuses to add her to the phonebook and she asked "is it because I shouted at it?"

Anyone else seen this? I Googled around and found this is one of the old issues : R Link can't find telephone numbers stored - My Renault ZOE electric car and Rlink - phonebook issues

Phone is LG G5, Android 7.0, 1 March 2018 security patch level (Expecting more updates to the LG G5? LOL!)
 

·
Registered
Joined
·
3,852 Posts
Maybe there is a special character associated with her name that stops it being added or shown? Or maybe too much additional data associated to her contact like a photo?

Try adding her to your contacts again as “the girlfriend” and see if it the. Syncs.

Or maybe the car is just trying to tell you something ;)

JJ
 

·
Registered
MG EZS 2020
Joined
·
4,861 Posts
There is a number to contact RLink customer services: Call 0344 369 0000 and log it as an error. They may have a 'fix', but most likely tell you to book it in for them to do something to it(?).

As an aside. You do know that the last bit after 99% is the BMS balancing the cells? You don't have to let it go to 100% if you don't want to, however it does help if you do go to 100% every 3rd or 4th go, it's okay to move off before 100% if someone is getting impatient.(y);)
 

·
Registered
Joined
·
425 Posts
Discussion Starter #4 (Edited)
There is a number to contact RLink customer services: Call 0344 369 0000 and log it as an error. They may have a 'fix', but most likely tell you to book it in for them to do something to it(?).
Oh I know, but I thought I'd try my luck on here first before they shrug and suggest something like factory resetting the R-Link or something (it's like the old "problem with your PC? Have you tried formatting it")

I come bearing an update. So I rang R-Link Connected Services and their official answer was "buy a new phone" (I kid you not). Apparently I should be "grateful" the phone even talks to R-Link at all. Turns out they have a list of phones they test against and if yours isn't one of them (even if it basically should be like every other Android 7) then that's your problem.

They suggested general tips like I should make sure my phone's bluetooth is actually on (thanks for that) and make sure I don't have the contact saved on the SIM but the phone instead etc etc. I had this contact like all the others as a GMail Contact rather than a phone contact. For giggles I changed it to Phone Contact and the phone warned me there may be some extra info that gets trashed by performing this move, I accepted. Performed a resync and R-Link then saw it. I then moved it back to GMail Contact like all the others and R-Link still saw it. As all the other contacts are saved as GMail Contacts this contact wasn't special in that regard which is probably why I didn't try this before.

So the issue? Some extra info in the contact is enough to trip it up. If you can afford to, switch to Phone Contact and back again and it'll trash whatever extra property it is and give it a new unique ID ready to be synced.

Unfortunately I don't know what the extra properties were otherwise I would have submitted a proper bug report to Renault with my "I know about programming" hat on.

As an aside. You do know that the last bit after 99% is the BMS balancing the cells? You don't have to let it go to 100% if you don't want to, however it does help if you do go to 100% every 3rd or 4th go, it's okay to move off before 100% if someone is getting impatient.(y);)
Yup and I like my cells always balanced ;). I almost exclusively only public charge so that 1% will always be an issue of contention.
 
1 - 4 of 4 Posts
Top