Speak EV - Electric Car Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
This seems like something I've seen on the other Nissan forums but not the ENV ones. My GPS displays the usual message on start up that it "can't connect the GPS [ok]" however in the past this would fix itself quickly and off we'd go. For the last few days it hasn't sorted itself and the ENV thinks it is driving around about 3miles to the east of here, jumping to the next plausible random road and generally getting confused. Any ideas for how to fix this?
 

·
Registered
Joined
·
1,032 Posts
If you're getting a comment about it not being able to connect to the GPS, then that has to be an indication of some fault with the system such as a failure of a component or wiring, meaning a trip to a dealer. The only GPS error I've ever had in either of my vehicles was once when driving in central London in a narrow street, when it thought I was on a parallel road, presumably due to the GPS signal getting obscured by the buildings.
 

·
Registered
Joined
·
2,620 Posts
All Nissan vehicles use similar equipment and so if there was a solution on one of the other forums then that might work on the e-NV200.
You could try restarting the computer by disconnecting the 12v battery for a while.
There is an option in the menus to “Adjust current location” in the navigation/settings/other menu but I wouldn’t want to suggest using that unless you know how to use that option.
Other than that, a visit to the dealer, sadly.
 

·
Registered
Joined
·
59 Posts
Discussion Starter #4
I just might try a couple of things. Disconnect the battery. Check the plugs at the back of the media unit (not sure the GPS has a separate socket but I could be wrong). I gather the head unit also knows the speed from the car so I might check nothing has changed since I swopped the tires over.
 

·
Registered
Joined
·
59 Posts
Discussion Starter #5
This is the GPS antenna on an ENV200 under the dashboard. At least I know where the plug goes now
127031
 

·
Registered
Joined
·
4 Posts
This seems like something I've seen on the other Nissan forums but not the ENV ones. My GPS displays the usual message on start up that it "can't connect the GPS [ok]" however in the past this would fix itself quickly and off we'd go. For the last few days it hasn't sorted itself and the ENV thinks it is driving around about 3miles to the east of here, jumping to the next plausible random road and generally getting confused. Any ideas for how to fix this?
Mine thought I was still in Bologne, France. Asked Nissan to take a peek - wire loose behind the stereo! Reconnected and now all is back to normal (albeit with 2016 maps since they've not issued an update since then!).
 

·
Registered
Joined
·
986 Posts
If it's important to know where you are, I'd suggest it's far cheaper to buy a satnav unit that attaches to the windscreen. For well under £100 you'd get one with free lifetime updates; if the vehicle is out of warranty that wouldn't even pay for a Nissan 'technician' to look behind the dashboard.
 

·
Registered
Joined
·
59 Posts
Discussion Starter #8
Have you seen how easy it is to get behind the stereo? The dash surround just pops off in your hands. The Satnav is working again. I left the car on outside parked up and it reacquainted itself successfully.
 
1 - 8 of 8 Posts
Top