Speak EV - Electric Car Forums banner

1 - 20 of 31 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
Hi Guys I'm after a bit of help with setting up Leafspy Lite, I plugged the Mini OBD 11 dongle in and get a red light on it and my phone finds the dongle and connects but on the Leafspy it stays yellow in the bottom corner and says retry 2.1 or something similar and no matter how many times I unplug or restart the phone it searches, finds and then displays the same message, I have lost the will with it now, my phone is a Samsung Galaxy S4 and the car is a Gen 2 2013, any help will be gratefully received.
 

·
Registered
Joined
·
8,106 Posts
IIRC you have to actually select the bluetooth dongle in the LeafSpy settings. It won't just connect on its own the first time. It will after that first connection though :)
 

·
Registered
Joined
·
40 Posts
Discussion Starter #3
I did that and it finds it ok but just won't connect? I have done this previously in other cars without problems but this one seems to not like me.
 

·
Registered
Joined
·
8,106 Posts
Sorry if you have already checked this but is it ELM 327 compatible ? I only ask because some of them are not!
 

·
Registered
Joined
·
40 Posts
Discussion Starter #5
Yes it is a mini OBD11 ELM327 device exactly the same one as you have Paul so I am a bit puzzled
 

·
Registered
Joined
·
40 Posts
Discussion Starter #8 (Edited)
Eh? Sorry I'm not following do you mean that you believe there is a setting in the car to enable it or are you asking whether it is actually plugged in to the diagnostic port? as far as I am aware the diagnostic port is permanently enabled and yes it is plugged in to it hence the previous statement about the red light being on, sorry if I have got the wrong end of the stick or I am missing a joke somewhere.
 

·
Registered
Joined
·
226 Posts
The LEAF needs to be 'active' - ready to drive basically. I usually plug in the bluetooth adaptor first, spark up the car (making sure its Bluetooth is off just incase), then open LEAF spy. The adaptor is paired to my phone (Galaxy S2) so the stats pop up quite quickly.
 

·
Registered
Joined
·
8,106 Posts
Ah yes... it needs to be on to do the initial connection but can be turned off afterwards and it should still continue working... Thx, forgot that :;
 

·
Registered
Joined
·
8,106 Posts
Where do you live Ian? Perhaps someone could meet up and have a test with their dongle/phone?

I would gladly help... I am in Cornwall/Devon/Somerset area :)
 

·
Registered
Joined
·
40 Posts
Discussion Starter #13
That's very kind Paul I'm in Northampton I will pop the kettle on, you can charge when you get here lol
 

·
Registered
Joined
·
8,106 Posts
LOL! Well, we are at Bletchley Park on the 25th Oct so if you haven't got it fixed by then let me know but there are lot of members from around your way so I don't suppose you'll need me :) :)
 

·
Registered
Joined
·
40 Posts
Discussion Starter #17
No, I downloaded Pro but it won't connect and keeps throwing up an error code saying that the socket may be disconnected or some such, I now wonder whether the adaptor is faulty.
 

·
Registered
Joined
·
377 Posts
shame you not near me im in dartford, i do venture over but only after 10pm
to tight to pay the £2
 

·
Registered
Joined
·
40 Posts
Discussion Starter #19
Still no joy with this, I have tried 2 separate dongles now and they both say read failed socket may be closed, any more ideas guys?
 
1 - 20 of 31 Posts
Top