Speak EV - Electric Car Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Greetings All,

Didn't realize the port was damaged until coming back home and trying to plug it in... See pictures below...

At the dealership now, they said part of the plug looks to be melted into the port and the assembly needs to be replaced, hopefully it'll get fixed under warranty :?

Searching around online, and this seems to (hopefully) be an extremely rare occurrence - I couldn't find any other events similar to this from my quick search?

They are asking for pictures of what the charger/charger's plug looks like...that charger probably wont be working for visitors after us...hopefully at least...

Pictures of the port...







Album: Damaged i3 Charging Port...thanks SemaCharge
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Greetings All,

Not quite sure its the same as the Blink issue - it looks like part of the plug broke off into the port in the car as oppose to full blown melting the port with the blink chargers..As far as temperature goes - I asked the better half (she was using it that day) - she didn't notice anything odd (ie difficulty plugging/unplugging, heat, noises, etc) - then again this is the first week we've had an EV...

The more I look at the picture, the more it looks like just a chunk of the charger plug got stuck in one of insulated ports - not so much melted..hopefully we'll get confirmation of the issue later today...
 
1 - 7 of 7 Posts
Top