Speak EV - Electric Car Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey guys - I've been reading this forum for a while now, recently got an MG ZS and enjoying it immensely!

However, we've recently come across a regen issue. Seemingly at random times (and at random battery levels) our LVL3 regen turns off - and the message you see when you have a full battery (manual breaking is required) comes on.

I've heard this is sometimes needed to make sure the brakes don't seize up but it's happening a lot - on and off for the last 100 miles I'd say.

We took it to Chorley MG who said the issue was normal and the vehicle is doing what it should.

I know I'm new to EV's - but never heard this mentioned by anyone else?
 

·
Registered
Joined
·
2,069 Posts
Have never seen the "manual braking" message other than when the battery is full (not even sure I have seen it since the January BMS fix).

In very cold weather (<5ºC or so) regen can be very weak, but I don't recall that triggering the message: you just feel less deceleration on lifting.

Summary: I can't confirm or refute what Chorley have told you!
 

·
Registered
Joined
·
174 Posts
I have seen the message at least once other than when the battery is full. I think it was on a very cold day.

My understanding is that the message isn't in principle triggered by the battery being full, but rather by it being unable to accept charge at the rate that regen braking could deliver.

Obviously a full battery would be a prime example, because you don't normally charge nearly full batteries quickly. But it is at least credible that other combinations of charge and temperature might fulfil whatever the criteria are.
 

·
Registered
Joined
·
2,638 Posts
Even my Model 3 limited regen until the pack was warm. It’s just a thing EVs sometimes do
 
  • Like
Reactions: Neilew
1 - 5 of 5 Posts
Top