Speak EV - Electric Car Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a Kangoo 2012 on a 62 plate, its done 46,000 miles. The van has a fault that come up on a scanner as DTC0440 insulation error detected. From what I can see this means the van needs a new motor, the current motor is a 5AM400. These seem rare as hens teeth.....Can we fit a 5AM450?
 

·
Registered
40kW Leaf Tekna & 22kW Zoë Q210 dynamique intens
Joined
·
743 Posts
Have you considered sending your existing motor to a rewinders to have it repaired?

there are many such places that do this kind of work:

143606
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
We did consider that and had a ring around but couldn't find anyone that had done a Kangoo motor, and then thought the cost might be more than a brand new motor. But we cant find a new 5AM400. The van drives fine, it's just not regenerating braking. I'll give these a call tomorrow thanks
 

·
Registered
40kW Leaf Tekna & 22kW Zoë Q210 dynamique intens
Joined
·
743 Posts
We did consider that and had a ring around but couldn't find anyone that had done a Kangoo motor, and then thought the cost might be more than a brand new motor. But we cant find a new 5AM400. The van drives fine, it's just not regenerating braking. I'll give these a call tomorrow thanks
Are you sure it’s the motor?

If it drives but won’t regen that could potentially be a fault with the inverter.

There is a company called Cleevely Electric vehicles in Cheltenham that may be able to help you:


They repair ev components and are generally much cheaper than the dealers when it comes to resolving issues such as this.
 
1 - 5 of 5 Posts
Top