Speak EV - Electric Car Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Have tried searching the forums for this issue but I might be naming the screen in a basic way that doesn't let me find it so here goes:

This is the first time this has happened but today during a 130 mile round trip with the Leaf and after fast charging it on an Ecotricity (not that I think matters) the touch screen in the car started to glitch by not letting me change screen. This happened when the navigation was on and I tried moving it to the radio, it worked at first but then the screen would not respond to my taps, being effectively frozen on the radio.

The only way I managed to 'reset' it was by turning the audio off (pressing the volume button in) and turning it on again.

This made it work again until I went back to the map screen, where it would freeze back and be non-responsive, until I would press the button in once more.

This usually wouldn't worry me but since I'm doing a European road trip in a couple of weeks it is worrying me a bit as I start thinking that this may be the start of a bigger problem?

Has anyone suffered from anything like this? I'm hoping to call our local Nissan dealership to see if I can get the car in before our travels.
 

·
Registered
Joined
·
30 Posts
Just wondered if you had used hand sanitiser or cream, can sometimes effect screen contact response.
Drives us mad on work touch screens.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
Hi Troy, thank you for replying, unfortunately, that wasn't the case. I have had it happen a few other times like you said but no cream was involved in yesterday's driving!
 
1 - 3 of 3 Posts
Top