Speak EV - Electric Car Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Manual says not to unplug car till the solid white light goes out as this means the battery management system was doing the batteries, how long does it take to go out, cars seems to fully charge in 4 and half hours then the mg sign light stops on.
I did unplug car while light was on and did not seem to cause any problems, just want to make sure just in case.
 

·
Registered
Joined
·
1,410 Posts
The solid light means that the car has charged to 100% and is now balancing batteries. In normal times this should take less than 30 mins. There have been some well reported issues of cars with faulty BMS softtware taking a very long time to balance (and in some cases failing to balance at all). You should keep an eye on the voltage when fully charged - it should likely be 449v for most recent software of possibly 455v for earlier release. If it is much less than this or if your car is regularly taking more than an hour to balance, then do check with your dealer.

Stopping charging before balance is complete will not do any harm.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Thanks for the info, just with the manual not saying its ok to unplug before its finished, but when you think about when you using public charges you have to end charge early.
Did have the on charge tonight everything was fine i did wait and light did go out.
Only had the car 2 weeks its a exclusive 20 plate.
 

·
Registered
Corsa SRI Nav Premium
Joined
·
5,089 Posts
possibly 455v for earlier release.
Mine goes to 453v each time now. Does that mean my battery has degraded? Latest update was not done at the last service, where the SOH was reported as 80%. I thought this was just a lazy workman. Looks like I may be wrong!
 

·
Zoe Devotee
Joined
·
9,380 Posts
Mine goes to 453v each time now. Does that mean my battery has degraded? Latest update was not done at the last service, where the SOH was reported as 80%. I thought this was just a lazy workman. Looks like I may be wrong!
Still cold at night, might be restricting that last couple of % charge. Have you got OVMS to check?

My car was serviced last Monday. I checked my SOH (100%) and my max V at 100% which was 456V. After the BMS update my SOH is still 100% and my max charged V is 449.5V.

Seen no change in range, in fact its gone up slightly, not the massive jump some have seen (with the similarly massive lost of range when driving). I'm seeing 171miles in Eco and no reason to disbelieve that at present. Only covering about 50miles over weekends at the moment and still has over 120miles showing available. It'll get a few short trips during the week and charged to 100% on Friday.

Just a few weeks until we can leave the region again, at which point the weekend long day trips will recommence. (y)
 
  • Like
Reactions: Neilew

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
Hi Guy, I had the car on change yesterday and just left it till mg light at front went out.
On checking car in morning before going out i had a range of 195miles, last time i charged i had 183miles so i must be doing something right lol.

Used eco mode today traveling from sunderland to weardale its about 40miles and what a difference it is to drive then my BMW i3 i had, although the BMW i3 is a lot quieter no electric motor sound.
 

·
Registered
Corsa SRI Nav Premium
Joined
·
5,089 Posts
Still cold at night, might be restricting that last couple of % charge
Yeah, I'll keep an eye on it. Hopefully the warmer weather will do the trick. If not only another 11 months before I look for the next one. I was hoping this one was going to be a keeper. I really enjoy driving it and it's Tesla features for an MG price.
 
  • Like
Reactions: rogerdee and TJEV

·
Registered
Joined
·
1,410 Posts
Mine goes to 453v each time now. Does that mean my battery has degraded? Latest update was not done at the last service, where the SOH was reported as 80%. I thought this was just a lazy workman. Looks like I may be wrong!
I'd be surprised and alarmed if the SoH was down to 80%. Don't think anyone else has reported less than 97% yet. I'd be less worried if showing a volt or two less than anticipated - remember you will only achieve the expected level when charged to 100%, balanced, nothing on drawing any current, warm temperatures etc.

I now make a point of checking voltage after every balanced charge and would be speaking to the dealer if there was any pattern of change.

Notwithstanding the evidence that MG have released faulty software in the past, I subscribe to the view that we should be running the latest authorised software versions as they are designed to offer the best balance between features, performance, reliability and longevity.
 

·
Registered
Joined
·
90 Posts
Hi Guy, I had the car on change yesterday and just left it till mg light at front went out.
On checking car in morning before going out i had a range of 195miles, last time i charged i had 183miles so i must be doing something right lol.
Stef63,

What are your volts showing as after a full charge and do you have any idea how long it is taking for your balance (solid) light to go out after the flashing light has finished?
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top