Speak EV - Electric Car Forums banner

1 - 20 of 28 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
My Outlander PHEV is the 2015 model (with a handbrake) and on buying the car I struggled but eventually succeeded to install the PHEV app on my 4-year-old. smartphone (I needed the oldest App for 10 digit passwords).
However I recently bought a new smartphone with the latest Android and REALLY struggled to get the App I installed. on this new phone to register with the car.
In desperation I turned to the Google Playstore and was horrified to read all of the bad Reviews and contradictory installation advice that is posted there. (Mitsubishi absolutely need to seriously and urgently upgrade this App but that’s another story).
Anyway I thought to offer here, the solution that worked for me. Again it’s not obvious and of course not stated anywhere in the instructions.
When launching the App and attempting to register the phone with the car, DO NOT first use you phone to change your wi-if network to “connect” to the car, BEFORE attempting to register with the car using the App. Instead, what you need to do is just leave the phone’s wi-if alone (typically it’ll already be connected to you home) and allow the Registration process of the App to change the Wi-fi connection automatically for you.
Simple when you know how. Well a bit simpler anyway ...
 

·
Registered
Joined
·
1 Posts
Nick - thanks for posting the advice. I'd already tried this, and also followed similar advice buried deep on a Mitsubishi web-page to 'forget the car's SSID from the phone's WiFi setup - nothing worked for me, but here it is anyway:-

<< In Android 6.0 or later devices, you may not be able to register. In this case, please delete the Wi-Fi profile for the vehicle. (If you use the MITSUBISHI Remote Control for the first time, it is not necessary to do this procedure.)

"Settings" - "Wi-Fi" - Select your vehicle "SSID"
If a "FORGET" button is appears, please tap "FORGET"
On certain Android devices, you may not be able to register due to automatic disconnection from the vehicle network. In such a case, please go to Android OS settings and ensure that the following settings are "OFF", then try to register again. (Depending on the device, setting sequence and display items may be different. For more information, please contact the device manufacturer.)

"Settings" - "Wi-Fi" - "Advanced"
"ADAPTIVE WI-FI" > OFF
"Switch to mobile data" > OFF
"Smart network switch" > OFF
"Auto network switch" > OFF
"Check for Internet service" > OFF
"Wi-Fi Auto ON/OFF" > OFF
"Intelligent Wi-Fi" > OFF
"Wi-Fi +" > OFF
"Avoid poor connections" > OFF
"Wi-Fi frequency band" > Automatic or 2.4GHz only >>


The general consensus seems to be that the latest versions off Android have broken the app for now - it's clunky as Hell anyway, so let's all hope for a complete re-write. No..?
 

·
Registered
Joined
·
40 Posts
Discussion Starter #3
Another irritation for me, is that I allow my phone to autoselect the strongest WiFi signal and to auto connect to this. So when anywhere near the car the phone now connects to the PHEV Wi-Fi which of course has no access to the Internet (its a design feature for security reasons).
Result: All Apps on my phone stop working, including satnav.
Solution: remember to turn off the Wi-Fi of my phone before approaching and getting into it. Use 4G networks for data instead.
 

·
Registered
Joined
·
36 Posts
Decided to try the app yesterday. Connected my iPhone XS in seconds. App works without issue. Tried connecting my wife's Samsung S9+ .... not a chance. All that happens is her phone says the app was written for an older version of Android and to update it.

I suppose the lesson is use an iPhone. The closed eco-system and strict controls over the OS mean developers only need to keep one version of the app up to date rather than multiple versions for different versions of Android on different platforms.
 

·
Registered
Joined
·
66 Posts
Hi. Was your car security updated ? Did you get the new 14 digit password ? I have been trying to install this app for months now. .. nothing is working and that's a joke really .tried many many solutions for many many hours and still nothing... Tried on few different phones as well.... Sooo much time wasted .. thanks
 

·
Registered
Leaf 30kWh, Outlander PHEV
Joined
·
2,398 Posts
Hi. Was your car security updated ? Did you get the new 14 digit password ? I have been trying to install this app for months now. .. nothing is working and that's a joke really .tried many many solutions for many many hours and still nothing... Tried on few different phones as well.... Sooo much time wasted .. thanks
I purchased Outlander last week to find out that password along with booklet was old.

Emailed customer service who promptly emailed the new password in their database. Problem was that didn't work either.

After bitching a bit, I called the dealer that updated the password during last service.

Turns out CS told me one ending with S. Correct one had 5.

If you gave issues, email customer services or called the dealer

[email protected]

Sent from my SM-G973F using Tapatalk
 

·
Registered
Joined
·
66 Posts
Thanks Hermit Dave.
I will try that but according to hundreds of reviews regarding this app online I am not having much hope. Thanks anyway.
 

·
Registered
Leaf 30kWh, Outlander PHEV
Joined
·
2,398 Posts
Thanks Hermit Dave.
I will try that but according to hundreds of reviews regarding this app online I am not having much hope. Thanks anyway.
Don't get me wrong, the app when it works isn't too bad.

After 2 days, it drops Wi-Fi connection within seconds so I can't set timer properly.

Going to try on s10 tomorrow

Sent from my SM-G973F using Tapatalk
 

·
Registered
Joined
·
66 Posts
That's exactly what I mean. I really can't believe how such huge company with so much experience in technology can't develop a simple working app for their product....
Unreal...
Good luck buddy and let us know.
I have tried one plus ,Samsung,Xiaomi ,mi max and nothing....
Accepts the password and goes to connecting screen and after few circle rounds goes straight to error code and can't connect..... Tried the Mitsubishi solutions with all possible error code list and guess what..... Still no luck .
Learned to live with out this app ;)
 

·
Registered
Joined
·
506 Posts
The old app worked without any issues before the upgrade. The new one works without any issues since the upgrade - it just connects and does what I ask. What's not to like?

I'm not going to post a review in the app store saying it's fine and I assume thousands of other people are not doing it either.
 

·
Registered
Leaf 30kWh, Outlander PHEV
Joined
·
2,398 Posts
The old app worked without any issues before the upgrade. The new one works without any issues since the upgrade - it just connects and does what I ask. What's not to like?

I'm not going to post a review in the app store saying it's fine and I assume thousands of other people are not doing it either.
It is working better on Samsung S10 than it did on iPhone XS

Sent from my SM-G973F using Tapatalk
 

·
Registered
Joined
·
18 Posts
New GX4H owner here and I'm just wading through the owner's manual and this forum. I see there is more than one app on the Play Store. Which one should I go for? I've got a Samsung S9.

TIA
 

·
Registered
Joined
·
66 Posts
Only one for outlander.
Different one for Shogun .
You want the outlander phev one .
Make sure you get genuine Mitsubishi one
And good luck brother 👍
You gonna need it .
 

·
Registered
Joined
·
18 Posts
I downloaded Mitsubishi Remote Control version A.3.1.0
I tried it a few hours ago and it was all going well until it came to the enter SSID and Password page. Blank screen with no way to enter anything.

Who do so many car manufacturers have do much difficulty with apps? VW are having a nightmare with the software fire the i.d.3 too.
 

·
Registered
Leaf 30kWh, Outlander PHEV
Joined
·
2,398 Posts
Kill the app and try again.

Sent from my SM-G973F using Tapatalk
 

·
Registered
Joined
·
7 Posts
I’ve just had this issue today as I don’t often use the remote charging or heating/cooling functionalities.
My outlander went in for the security recall in June and I hadn’t been advised the SSID password had changed, nor was I given any paperwork other than the copy of the job sheet to authorise the work.

Fortunately an easy resolution for me, I put a call in to the dealership and they found the paperwork that should’ve been given to me which contains the new password. It’s being sent out by post but they’ve also sent me an SMS. Yet to try it out but will likely do tomorrow, will update With success or failure.
 

·
Registered
Leaf 30kWh, Outlander PHEV
Joined
·
2,398 Posts
Reset the app connectivity and pair again using the app.

Sent from my PH-1 using Tapatalk
 

·
Registered
Leaf 30kWh, Outlander PHEV
Joined
·
2,398 Posts
Anyone got any suggestions to overcome this error message? Husband thinks the car is preventing access to my phone.
Did you reset the app connectivity??


Sent from my PH-1 using Tapatalk
 
1 - 20 of 28 Posts
Top