Speak EV - Electric Car Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter #1
I'm so glad I ignored my (MG) dealer's recommendation and went with EVM's recommendation of Ohme charger for my new MG ZS EV. Not only is it currently the ONLY charger in the UK which fully supports the Agile Octopus tariff (probably the best tariff in the UK for EVs) but they've now made themselves the ONLY charger in the UK to correctly shedule-charge the MG ZS EV (the MG has a firmwar bug in the car which defeats normal scheduled charging by smart chargers). They download updates over the air, so my charger "magically" suddenly supports my car correctly! - this his how modern technology should be...
BTW, I'm in no way associated with Ohme - just a very satisfied customer!
 

·
Registered
Joined
·
90 Posts
Discussion Starter #3
That's a shame - what's the issue? has there been a fault in your local mobile phone mast? the Ohme uses the mobile phone network, so a mast down, or interference coming up, may affect it.
 

·
Registered
Joined
·
11 Posts
Could be something like that, possibly after the storms I suppose. It’s a shame because I bought this specifically because of the potential you mention above - seem like a progressive company that want to stay ahead of the curve. Hopefully it’ll be back to normal soon.
 

·
Registered
Joined
·
11 Posts
They replied with a very brief note and explained that my grey app screen was due to the connection loss. However they offered no further advice or possible remedy and haven’t responded to my question about whether I should try turning the power off to see if it reconnects when the power comes back on.
 
1 - 6 of 6 Posts
Top