Speak EV - Electric Car Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
233 Posts
Discussion Starter · #1 ·
Just taken delivery of my (at the moment) wonderful new 4+. Rushed home and started all the work needed these days when you buy a car. Set up MyKia - created an account, everything worked OK. Downloaded UVO. Started it - it demanded a KIA account. Put it the MyKia account details - uh oh! Not Recognised. Cut a long story short - played around for a long time - could not get logged in. Right - I'll do it from the PC. Uh oh - not recognised. So I decided, **** this, and chose the create new account option. Filled in all the details, uh oh, phone number not recognised. WHAT!
Tried 077****, no go. Tried 077** space **, no go. Tried home landline - no go.
What the :censored: do I have to do to get into UVO?
Can anyone help, please?
Thanks
Silverback
PS : At the moment, the 4+ is wonderful. Once I've finished my degree course in Kia E-Niro 4+ options, I'll be off and running. o_O
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top