Speak EV - Electric Car Forums banner
1 - 20 of 22 Posts

·
Registered
Joined
·
121 Posts
Discussion Starter · #1 ·
Hey,

I placed my order (paid, filled out OLEV grant and their site survey pics and form) a week ago today and it's like the company has vanished off the face of the earth.

Leading up to deciding to get a Pod Point what convinced me to get it was that they were the only company that was replying to questions/emails within a few hours, everyone else I emailed with questions, some haven't even replied yet (Special award to Chargemaster in particular who took... let me count here... 38 days to reply to my email, when I replied back it said the address was no longer used and it's still on their website as their primary contact).

Since then I've emailed twice without reply, phoned and was assured they would get back to me with an answer and yet?

They feel like a car dealer, got my money now, who cares!
 

·
Registered
Joined
·
30 Posts
Hey,

I placed my order (paid, filled out OLEV grant and their site survey pics and form) a week ago today and it's like the company has vanished off the face of the earth.

Leading up to deciding to get a Pod Point what convinced me to get it was that they were the only company that was replying to questions/emails within a few hours, everyone else I emailed with questions, some haven't even replied yet (Special award to Chargemaster in particular who took... let me count here... 38 days to reply to my email, when I replied back it said the address was no longer used and it's still on their website as their primary contact).

Since then I've emailed twice without reply, phoned and was assured they would get back to me with an answer and yet?

They feel like a car dealer, got my money now, who cares!
With my experience it took about 3 weeks. Ordered online 16th September and I received an email on 28th September to advise installation is on th 9th October.
I think they email you when they can schedule you in for installation, the waiting time varies depending where you are. Have you tried calling them? I have to ask a question prior to then setting a date for the install. It did take a while for them to answer but my call was answered. Overall my experience has been positive.
 

·
Registered
Joined
·
115 Posts
I got my PodPoint as part of the deal with my car, Corsa E.

Initial contact took a while but after that everything took place quickly with regular email contact.

What I really liked about Podpoint is the Email actually had the reps name on it and it was the same person I always spoke with. Genuinely very happy with Podpoint and one of the few companies that I enjoyed dealing with .
 

·
Registered
Joined
·
121 Posts
Discussion Starter · #5 ·
I finally got it installed today - 33 days from paying to install, not sure if that's normal or not.

Anyone know how long it takes to be able to add to the app? Installer was vague and said I needed to wait for an email before I could do it? If I try to add it now it says there was something wrong and I need to contact Pod Point.
 

·
Registered
Joined
·
115 Posts
Hmmm, Installer should have got the PodPoints WIFI linked to your homes and it should work straight away. Thats how it went for me.

Have you downloaded the app and added your unit?

What colour light is showing on your unit?
 

·
Registered
Joined
·
121 Posts
Discussion Starter · #7 ·
Hmmm, Installer should have got the PodPoints WIFI linked to your homes and it should work straight away. Thats how it went for me.

Have you downloaded the app and added your unit?

What colour light is showing on your unit?
Hey, he connected it, a new device is showing on the router, so pretty sure it's connected - the light is blue.

When I try to add the unit in the app it says there's something wrong and to contact support - but he said I needed to wait for an email first before I could do it.
 

·
Registered
Joined
·
115 Posts
If all is well you should have a blue light with a magenta flash every few seconds.

I got my Podpoint in the summer and tbh I dont remember having to wait for an activation email, it just worked after I downloaded the app and put in the serial no.

Maybe things have changed since then or I've forgotten due to the uptake in alcohol consumption during various lockdowns 😆
 

·
Registered
Joined
·
115 Posts
I wouldn't worry though, I've found Podpoints support via email to be very good.

If you have an issue they'll get it sorted 👍
 

·
Registered
Joined
·
30 Posts
I finally got it installed today - 33 days from paying to install, not sure if that's normal or not.

Anyone know how long it takes to be able to add to the app? Installer was vague and said I needed to wait for an email before I could do it? If I try to add it now it says there was something wrong and I need to contact Pod Point.
It took about half a day before I got an email to confirm the unit was linked to my account.

However I had an issue where my unit serial number was registered at a different physical address! I had to contact Pod Point customer services team a few times to get it resolved. I only found this out when I used report download to see how much electricity I used. The address against my unit was to another customer home address, this was considered a data breach incident.
 

·
Registered
Joined
·
121 Posts
Discussion Starter · #11 · (Edited)
It took about half a day before I got an email to confirm the unit was linked to my account.

However I had an issue where my unit serial number was registered at a different physical address! I had to contact Pod Point customer services team a few times to get it resolved. I only found this out when I used report download to see how much electricity I used. The address against my unit was to another customer home address, this was considered a data breach incident.
Ohhh, so I do have to wait for an email before I can add it in the app?

He was so vague!

Edit - Been doing some googling and apparently the light should have been blue with a pulse of purple every few seconds, mine wasn't.

I turned it off at the mains, waited a few minutes and switched it back on, waited ten minutes and tried to add it to the app again and it worked first time.

Thought I'd post the fix in case anyone else has the issue
 

·
Registered
Joined
·
7 Posts
It took about half a day before I got an email to confirm the unit was linked to my account.

However I had an issue where my unit serial number was registered at a different physical address! I had to contact Pod Point customer services team a few times to get it resolved. I only found this out when I used report download to see how much electricity I used. The address against my unit was to another customer home address, this was considered a data breach incident.
I have the same problem trying to link the charger serial number to the app says the email has been sent to a different email address -very strange

tehki8 how did you contact customer services as last time i was on hold for 30mins only to be transferred to another department
 

·
Registered
Joined
·
30 Posts
I have the same problem trying to link the charger serial number to the app says the email has been sent to a different email address -very strange

tehki8 how did you contact customer services as last time i was on hold for 30mins only to be transferred to another department
Hi I called this number +44 207 247 4114. I was on hold for about 20 minutes, this was in October. I think I also emailed customer services
[email protected]
I had to call a second time on a different day to get them to sort out the issue.
 

·
Registered
Joined
·
7 Posts
what was their reason for the unit ser# being linked to another email address already?

im not in a hurry to have it linked so gonna leave it until in to jan

thanks for your reply bud
 

·
Registered
Joined
·
30 Posts
what was their reason for the unit ser# being linked to another email address already?

im not in a hurry to have it linked so gonna leave it until in to jan

thanks for your reply bud
I can't recall the full and exact reason. I did ask if it was the installation engineer registered the unit to the a different email address when commissioning the unit, the customer service agent said no. Assignment is done centrally. So I am not sure if that means he installed another customer unit at my address. Because when I got the app linked to my unit I used the report download option. In my report the home usage kWh had an address from another house in near by town and not my home address. I called them up again to have the address issue fixed, this was a GDPR data issue. Pod point are still working out how my unit was linked to a different physical address.
 

·
Registered
Joined
·
7 Posts
I can't recall the full and exact reason. I did ask if it was the installation engineer registered the unit to the a different email address when commissioning the unit, the customer service agent said no. Assignment is done centrally. So I am not sure if that means he installed another customer unit at my address. Because when I got the app linked to my unit I used the report download option. In my report the home usage kWh had an address from another house in near by town and not my home address. I called them up again to have the address issue fixed, this was a GDPR data issue. Pod point are still working out how my unit was linked to a different physical address.
at first when i got the already linked email message i thought reconditioned charger units!!
 

·
Registered
Joined
·
121 Posts
Discussion Starter · #18 ·
To solve my woes of the Pod Point not doing charge scheduling or well, being smart - I ended up getting an Ohme smart cable (type 2 to type 1) because it's on offer with Octopus at the moment (£150) and it now does everything I want it to, wish I'd just got one of those in the first place to be honest!

You live and learn
 

·
Registered
Joined
·
10 Posts
Hey,

I placed my order (paid, filled out OLEV grant and their site survey pics and form) a week ago today and it's like the company has vanished off the face of the earth.

Leading up to deciding to get a Pod Point what convinced me to get it was that they were the only company that was replying to questions/emails within a few hours, everyone else I emailed with questions, some haven't even replied yet (Special award to Chargemaster in particular who took... let me count here... 38 days to reply to my email, when I replied back it said the address was no longer used and it's still on their website as their primary contact).

Since then I've emailed twice without reply, phoned and was assured they would get back to me with an answer and yet?

They feel like a car dealer, got my money now, who cares!
My only experience is with PodPoint is with a workplace charge point. They took 7 months to finally fix a faulty charge stand. In those seven months they only came out 4 times. This was all in 2019, so COVID-19 wasn't an excuse!
 

·
Registered
Joined
·
437 Posts
There is a broken Pod-Point Pedestal Charger at Orbis Energy in Lowestoft. One half is totally off and the other only works at 3.6kW. So it's painfully slow. I've reported it broken at least 6 times but still not fixed. It's just poor. I can't imagine Orbis energy are very happy with having the slowest public charger in Lowestoft!
 
1 - 20 of 22 Posts
Top